Opened 16 years ago

Closed 16 years ago

Last modified 10 months ago

#1540 closed defect (fixed)

GUI: Bad path selector positioning in full screen mode

Reported by: SF/msephton Owned by: fingolfin
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

ScummVM 0.6.0 - 14 March 2004
Mac OS 10.3.3
ScummVM front end problem

Background: When adding a new game you are prompted with a
path selector dialog. Under Mac OS X this is a standard operating
system dialog.

Detail: In full screen mode the dialog is positioned half off screen,
luckily you can press ESC to cancel

Reproduction: launch ScummVM in full screen mode. Click Add
game.

Ticket imported from: #917697. Ticket imported from: bugs/1540.

Change History (5)

comment:1 by fingolfin, 16 years ago

Owner: set to fingolfin

comment:2 by fingolfin, 16 years ago

Summary: Bad path selector dialog positioning in full screen modeGUI: Bad path selector positioning in full screen mode

comment:3 by fingolfin, 16 years ago

Fixed in CVS, by enforcing windowed mode when adding a game. It
seems virtually impossible to get the nav dialog right in full screen
mode, due to window layering issues (popup menus are windows, too,
see also your other bug report).

comment:4 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed

comment:5 by digitall, 10 months ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.