Opened 16 years ago

Closed 15 years ago

#1528 closed defect (fixed)

DIG: Crash on imuse sound assert

Reported by: SF/qknight Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

first of the game runs well.
after the first time you are on atila you have to pull some
metal plates. after collecting these and trying to place them
in the form the game crashes with the below console
output.

my fix is to comment the linux 47 out, then its working but i
dont think this is the right way.

==================
Line 47 in scumm/imuse_digi/dimuse_music.cpp

assert(_digStateMusicMap[num].unk1 < 11);

i do
//assert(_digStateMusicMap[num].unk1 < 11);
then recompile it and its gone. I do not know if there are
errors afterwards because its not bugfixed correctly if at all.

hope someone can fix that :-)

good work so far!
i liked to see that the scrolling bug is gone. you "can" no
move back. in 0.3.0 you could get stuck in a few rooms!

didnt test all of them!

==================
Console output:

Switched to configuration /home/meli/.scummvmrc
Looking for dig
Trying to start game 'The Dig'
scummvm: scumm/imuse_digi/dimuse_music.cpp:47: void
Scumm::IMuseDigital::setDigMusicState(int): Assertion
`_digStateMusicMap[num].unk1 < 11' failed.
Aborted
meli@debian:~/tmp/scummvm$

Ticket imported from: #915060. Ticket imported from: bugs/1528.

Change History (8)

comment:1 by fingolfin, 16 years ago

Owner: set to aquadran
Summary: Crash on imuse sound assert, CVS version from 20040312DIG: Crash on imuse sound assert

comment:2 by fingolfin, 16 years ago

When an assert gets triggered, that means the game is in a bad state.
Think of it like an emergency brake. Sure you can remove it and go on a
bit more, but don't complain if you rush headlong into a hard stone wall
that way :-)
"Fixing" an assert never means removing it (that's curing the symptoms,
not the cause).

comment:3 by fingolfin, 16 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 by SF/cavac, 16 years ago

Had the same problem with the exact error message.

Version is talkie/english, scummvm tested are:
One a ~0.5.7 from CVS and a current from today (0.7.0 from
CVS/Mar 21).

OS: NetBSD 1.6ZI

The bug always happens when entering the NEST after
Maggie got captured by that monster thingie.

comment:5 by SF/cavac, 16 years ago

How do i attach a savegame file? I didn't find any option...

comment:6 by fingolfin, 16 years ago

You can only attach a file to a bug report if you either filed it yourself, or
if you are a team member.

comment:7 by fingolfin, 15 years ago

Since at least one very similar bug report is not reproducible with
current HEAD CVS, could you please check if you can reproduce this
problem with latest CVS?

Also, a savegame would still be useful. If you can't attach to this bug
report, either file a new one, or email me (fingolfin AT scummvm DOT
org)

comment:8 by aquadran, 15 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.