Opened 16 years ago

Closed 16 years ago

Last modified 6 months ago

#1522 closed defect (worksforme)

ALL: crash on fullscreen@hq3

Reported by: SF/jaho Owned by: fingolfin
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

scummvm seems to crash using 0.6.0pre and sdl 0.5.7
when I try to go fullscreen in 3x mode. I can use the
mode in windowed view, but not fullscreen. The problem
seems to be solved when I replace the sdl.dll with an
older version (e.g. 0.5.6) but then the games run slower.

I have a p4@1.4 256 sdr ram, nvidia geforce2mx400
winxp sp1 53.03 drivers.

Also, when i run scummvm from a fullscreen dos prompt,
it successfully initializes 3x fullscreen mode, but not in
1024x768, but at 1280x720 instead, which is very
uncomfortable.

Ticket imported from: #913313. Ticket imported from: bugs/1522.

Change History (8)

comment:1 by fingolfin, 16 years ago

Summary: crash on fullscreen@hq3ALL: crash on fullscreen@hq3

comment:2 by fingolfin, 16 years ago

SDL 0.5.6 ? HU ? Do you mean 1.2.6 maybe ?

And which games are you trying?

Are you only talking about HQ3, or about all 3x scalers ?

Final note, I can't reproduce this at all.

comment:3 by SF/jaho, 16 years ago

fingolfin, excuse me for the poor report. Indeed I meant
SDV.dll versions 1.2.7 (crashing) and 1.2.6 (working). I was
talking about scummvm crashing on all 3x scallers when trying
to go to fullscreen mode. I have tried many games - Indy4,
SmanMax, Dott, Maniac, BASS, it doesn't matter which game.

Maybe it's got to do with my graphics card new drivers 53.03
or something to do with XP, I don't know.

Anyways, it is playable with SDL.dll 1.2.6, so I will stick to
that.

Cheers

comment:4 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed

comment:5 by fingolfin, 16 years ago

Seems to be an SDL bug then, not a ScummVM bug. You might want to
send the SDL team a bug report (sadly there is no bug tracker for SDL,
but at least you can email them, contact information can be found on
libsdl.org)

comment:6 by digitall, 10 months ago

Component: --Unset--Port: Win32

comment:7 by Filippos Karapetis <bluegr@…>, 6 months ago

In f426ba6c:

SDL: Move fullscreen and screenshot event handling to SdlGraphicsManager (#1522)

comment:8 by digitall, 6 months ago

The previous comment was automatically added by pattern matching of #1522 in that comment as a bug artifact id. However, this was actually a reference to the Pull Request id and is unrelated to this bug. Not sure how to avoid this in future.

Note: See TracTickets for help on using tickets.