Opened 16 years ago

Closed 15 years ago

#1521 closed defect (fixed)

DIG: Crash when going back to canyon

Reported by: SF/pepepupu Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

ScummVM 0.5.7cvs CVS dated March 9 2004
Features compiled in: Vorbis MP3 ALSA zLib

When trying to enter canyon, scummvm aborts and says:

scummvm: scumm/imuse_digi/dimuse_music.cpp:47: void
Scumm::IMuseDigital::setDigMusicState(int): Assertion
`_digStateMusicMap[num].unk1 < 11' failed.
Aborted

Tried with older CVS-version (2. March). Works ok...

Ticket imported from: #912830. Ticket imported from: bugs/1521.

Attachments (1)

dig.s12 (21.2 KB ) - added by SF/pepepupu 16 years ago.
Savegame

Download all attachments as: .zip

Change History (6)

by SF/pepepupu, 16 years ago

Attachment: dig.s12 added

Savegame

comment:1 by fingolfin, 16 years ago

Owner: set to aquadran
Summary: Crash when going back to canyonDIG: Crash when going back to canyon

comment:2 by SF/gjasny, 16 years ago

Just a me too. It occurs with the HEAD CVS from Sunday 07.
March. I get the same assertion. Scummvm crashes when
inseting the last 'puzzle' piece. I've got a savegame but can't
attach it to this tracker item.

-Gregor

comment:3 by fingolfin, 15 years ago

Resolution: fixed

comment:4 by fingolfin, 15 years ago

I can't reproduce this with current (HEAD) CVS. So it seems aquadran
fixed it?

Please test & confirm / reject this claim :-)

comment:5 by fingolfin, 15 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.