Opened 4 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#15203 closed defect (invalid)

SCI: Hoyle School House: No Sound and Music

Reported by: OmerMor Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: OmerMor Game: Hoyle's Classic Card Games

Description

There is no sound and music when playing this game with ScummVM. The original interpreter plays fine.

Change History (5)

comment:1 by sluicebox, 4 weeks ago

Works for me; I spent a whole day listening to it!

comment:2 by eriktorbjorn, 4 weeks ago

Oh, I thought it didn't have sound. Cool! It's silent if I try to use FluidSynth or MT-32 emulation though, so that's what fooled me.

AdLib works, but once I start a card game the music fades out. Is that the intended behavior?

comment:3 by OmerMor, 4 weeks ago

You're right about Adlib. I only tried GM & MT-32.
Is it possible that useAltWinGMSound() should be updated to include this game (as well as the other Hoyles)?

I saw that Hoyle Classic Card Games (which is where this game got its music resource from) has a dos and windows sets of sounds (where the windows id = dos id + 1000), and this one has only the windows set.

comment:4 by sluicebox, 2 weeks ago

Owner: set to sluicebox
Resolution: invalid
Status: newclosed

Closing this ticket as there is sound and music and it plays correctly.

To clarify:

  1. This variant has sound resources with adblib channels but not MT32/GM channels. They play on a default ScummVM config (adlib).
  2. useAltWinGMSound is irrelevant to this variant.
  3. useAltWinGMSound is irrelevant to the real Hoyle5, because it does not contain sound resources. It only contains digital samples in audio resources.
  4. Sound fading is correct. That is Hoyle4 behavior and that's where these scripts come from.

comment:5 by eriktorbjorn, 2 weeks ago

Ah, I see. Judging by YouTube videos, the original hoyle4 plays music during character selections and introductions (which this version does not have), and when the game ends (which this version also does).

I guess this version is just even more crippled than I first thought. :-)

Note: See TracTickets for help on using tickets.