Opened 16 years ago

Closed 16 years ago

Last modified 11 months ago

#1511 closed defect (fixed)

ALL: Mouse glitches and crashes (Regression)

Reported by: Kirben Owned by: fingolfin
Priority: high Component: Port: Win32
Keywords: Cc:
Game:

Description

Latest ScummVM 0.5.7cvs version.
All games
Compiled under mingw with GCC 3.3.3 and running under
Windows XP.

Moving the mouse around leaves graphics glitches and
moving the move around in lower half of screen
eventually causes ScummVM to crash.

Ticket imported from: #907280. Ticket imported from: bugs/1511.

Change History (5)

comment:1 by Kirben, 16 years ago

I forgot to mention, this only occurs after last your last
change to SDL backend.

comment:2 by Kirben, 16 years ago

Summary: ALL: Mouse glitches and crashesALL: Mouse glitches and crashes (Regression)

comment:3 by eriktorbjorn, 16 years ago

One possible reason for crashing: there is a comment in
undraw_mouse() that states that there is "No need to do
clipping here, since draw_mouse() did that already". I don't
think that's true any more.

(Well, it does clipping of course, but not in any way that
undraw_mouse() can benefit from.)

comment:4 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed

comment:5 by digitall, 11 months ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.