Opened 2 months ago

Last modified 8 weeks ago

#15090 new defect

SCUMM: PUTTPUTT: Playing with Audio+Subtitles skips lines (original bug)

Reported by: Gimlao Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Putt-Putt Joins the Parade

Description

Right at the beginning, while the radio is speaking, if there are multiple lines during one audio dialog, it will only show the first line.

For example we can hear :
"Wake up all you swamp buggies and funny cars"

But we will only see this :
"Wake up all you swamp buggies..."

And we will not see this :
"...and funny cars..."

Then, oddly, if we set subtitles speed to 255, it will not skip these lines.

This doesn't happen with ScummVM 2.1.0 on Steam.

Change History (6)

comment:1 by AndywinXp, 2 months ago

Component: --Unset--Engine: SCUMM

comment:2 by AndywinXp, 2 months ago

Owner: set to AndywinXp
Resolution: invalid
Status: newclosed

Hi. This is not a bug, the engine (and the original executable) work exactly like that: whenever a speech line has a multi-line subtitle associated with it, skipping it skips the whole subtitle. I'll close this, as this is intended behaviour. Thanks for your inquiry!

comment:3 by Gimlao, 2 months ago

I think my ticket was misunderstood :

Maybe I was not clear enough
( I speak French, by the way )

I should record videos to compare ScummVM 2.1.0 and latest Daily Build

I am not skipping anything, the game just skips things by itself, we can only read the first line of every speech that have multi-line subtitles, so we can't read everything

Last edited 2 months ago by Gimlao (previous) (diff)

comment:4 by sev-, 8 weeks ago

Resolution: invalid
Status: closednew
Summary: Playing with Audio+Subtitles skips linesSCUMM: PUTTPUTT: Playing with Audio+Subtitles skips lines

comment:5 by AndywinXp, 8 weeks ago

I went back and made another comparison with the original: the EXE skips the subtitle line as well, so we could say that we're accurate. I won't close this for now though, as I'd like to see if there's something I could do to workaround this without breaking the subtitles subsystem.

comment:6 by AndywinXp, 8 weeks ago

Summary: SCUMM: PUTTPUTT: Playing with Audio+Subtitles skips linesSCUMM: PUTTPUTT: Playing with Audio+Subtitles skips lines (original bug)
Note: See TracTickets for help on using tickets.