Opened 2 months ago

Closed 8 weeks ago

#15046 closed defect (fixed)

Might & Magic I enhanced. Can not read Wallpix.dta, using legit gog files

Reported by: ybc2020 Owned by: ybc2020
Priority: normal Component: Engine: MM: MM1
Version: Keywords: MM1
Cc: Game:

Description

ScummVM 2.9.0git2796-gfe030bde704 (Mar 26 2024 04:15:29)

I posted in the forum but thought it may be a bug. Here's my post:

Hi there, hope someone can help. I tried installing Might & Magic 1 for the enhanced version using the daily build but it keep having error on wallpix.dta file. I use the gog file and other other version of MM1 but same error exist. I tried just the plain mm1 files, as well as adding the mm.dat and xeen.cc file into the folder but same error also come up. Appreciate someone may have a solution as the MM1 enhanced version looks quite good! Here's the log file:

[2024-03-26 22:15:34] ScummVM 2.9.0git2796-gfe030bde704 (Mar 26 2024 04:15:29)
[2024-03-26 22:15:34] TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth MikMod Theora VPX AAC A/52 FreeType2 FriBiDi JPEG PNG GIF taskbar TTS cloud (servers, local) ENet SDL2 TinyGL OpenGL (with shaders) RetroWave
[2024-03-26 22:15:34] --- Log opened.
[2024-03-26 22:15:40] Running Might and Magic: Book One - Secret of the Inner Sanctum - Enhanced (DOS/English)
[2024-03-26 22:15:40] wallpix.dta: 86a7ef03fd5bf434d83012b07fa92680, 123059 bytes.
[2024-03-26 22:15:40] Could not open file - blastmus!
[2024-03-26 22:15:40] Debugger started, type 'exit' to return to the game.
[2024-03-26 22:15:40] Type 'help' to see a little list of commands and variables.
[2024-03-26 22:15:40] ERROR: Could not open file - blastmus!
[2024-03-26 22:15:40]
[2024-03-26 22:15:40]
[2024-03-26 22:15:42] --- Log closed successfully.

Change History (3)

comment:1 by antoniou79, 2 months ago

I think the error does not have to do with the wallpix.dta file, but with a (missing?) blastmus file.

Testing on mine (Windows, with the GOG version of MM1, in enhanced mode) this happens when I've set Sound device as "Adlib Emulator".

There's also a similar error that can occur with other sound device options (eg. "MT32 emulator") where the error states not being able to read a "rolmus" file.

I've searched in my installations of MM1 and also MM4-5 and Swords of Xeen (all GOG releases) and I could not find such files. Perhaps the original releases do have these files and can be used?

But the alternative for me is to set the "Music device" to either "Microsoft GS Wavetable Synth" or "Fluidsynth" in the "Audio" tab. Keep in mind that the second option requires setting an external soundfont from the MIDI tab to be used by FluidSynth. And the first option is most likely not available on platforms other than Windows.

comment:2 by ybc2020, 8 weeks ago

Hi there, it looks like if I set the audio parameter in ScummVM lanucher within game option to midi, the game will load. I suggest if this can be added in the MM1 Game ScummVM Wiki page so this is known then it would be great to be able for others to know. Thank you! Very excited for this addition to ScummVM!

comment:3 by ybc2020, 8 weeks ago

Owner: set to ybc2020
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.