Opened 2 months ago

Closed 5 days ago

#15011 closed defect (invalid)

AGS: Heroine's Quest: Stamina refills automatically in hot springs (original bug)

Reported by: bliznik Owned by: tag2015
Priority: low Component: Engine: AGS
Version: Keywords: Heroine's Quest, stamina
Cc: Game:

Description

There's a bug in Heroine's quest where your stamina will sometimes be refilled. I was able to recreate this condition reliably during a playthrough. Using the savegame here, run (which depletes your stamina) E. N, E, S, E, E, N, E, S until you get to the hot springs. Then use the pick in the pack to grab some coral. This refills the stamina gauge for some reason. Not a game-breaking bug, but it's weird.

Attachments (1)

heroinesquest.zip (732.9 KB ) - added by bliznik 2 months ago.
savegame to recreate stamina refill bug

Download all attachments as: .zip

Change History (6)

by bliznik, 2 months ago

Attachment: heroinesquest.zip added

savegame to recreate stamina refill bug

comment:1 by tag2015, 2 months ago

Thanks for the report, but this is not a ScummVM bug. The same thing happens in the Steam version (I loaded your save, you just need to rename it as agssave.[anynumber].hqthor and put it in the saves directory).
This looks like a bug in the game script, or a regression in the AGS engine if it didn't happen on older versions (the latest update to Heroine's quest was in september)

comment:2 by tag2015, 2 months ago

Summary: AGS HEROINE'S QUEST: Refill of Stamina bugAGS: Heroine's Quest: Stamina refills automatically in hot springs (original bug)

comment:3 by Crystal-Shard, 5 days ago

What happens is that chiseling off the coral takes a long time. This is not shown on-screen but it advances the game clock. And advancing the clock refills your stamina.

Thanks for reporting, but this is not a bug.

comment:4 by tag2015, 5 days ago

Thanks for the explanation! Closing

comment:5 by tag2015, 5 days ago

Owner: set to tag2015
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.