Opened 4 months ago

Closed 3 months ago

#15009 closed defect (fixed)

SCUMM: Special keys are processed even when in an original GUI dialog

Reported by: eriktorbjorn Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game:

Description (last modified by eriktorbjorn)

I was trying to create a savegame in FM Towns Loom using the original save/load dialog, but when I tried to type an upper-case "S" as part of the savefile name I couldn't. Instead it toggled the sound on or off.

This happens in at least:

  • The EGA version of Loom
  • The FM Towns version of Loom
  • The VGA version of Indiana Jones and the Last Crusade

(Good thing at least one of these is still being sold, eh?)


This probably affects other keys as well, but I haven't had the time to investigate.

I'm guessing that it's a simple fix in ScummEngine::processKeyboard() because that's where the "S" key is hard-coded for some games. But I'm already late for work, so that's as far as I got.

Attachments (1)

indy3-glitch.png (9.2 KB ) - added by eriktorbjorn 4 months ago.

Download all attachments as: .zip

Change History (5)

by eriktorbjorn, 4 months ago

Attachment: indy3-glitch.png added

comment:1 by eriktorbjorn, 4 months ago

Description: modified (diff)

comment:2 by AndywinXp, 4 months ago

This is because SHIFT-s is manually bound to those option commands... On a SCUMM v4+ save menu it gets bypassed by design, but I'll have to put in special cases for these in-game menus. The original used ALT-* combinations, but they collide with our ScummVM backend shortcuts so it's a no-go.

comment:3 by eriktorbjorn, 4 months ago

Edit: Never mind, I misread your comment. Removed my question.

Last edited 4 months ago by eriktorbjorn (previous) (diff)

comment:4 by AndywinXp, 3 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.