Opened 7 weeks ago

Closed 7 weeks ago

#15005 closed defect (invalid)

mads:nebular crash to debugger in scene 604

Reported by: speachy Owned by: dreammaster
Priority: normal Component: Engine: MADS
Version: Keywords:
Cc: Game: Rex Nebular

Description

When exploring the abandoned city, if you try to travel to either the North Sea Window or the Residential location, the game crashes to the debugger:

ERROR: FabDecompressor - Decompressed data does not match header decompressed size!

According to the debugger we are in scene 604.

scummvm compiled from git, reproduced using:

ScummVM 2.9.0git2186-g126c19855a9 (Mar 2 2024 17:52:10)

This crash makes it impossible to complete the game.

The attached savegame can be used, get in the car and try to travel to either location. Alternatively you can enter the debugger and issue the 'scene 604' command to save time.

This happens with a fresh reinstall using the original Microprose installer.

Attachments (1)

nebular.006 (19.2 KB ) - added by speachy 7 weeks ago.

Download all attachments as: .zip

Change History (5)

by speachy, 7 weeks ago

Attachment: nebular.006 added

comment:1 by speachy, 7 weeks ago

Just to be explicit, this is from an original floppy installation. The 8.49 update is applied too, but that only changes the main .EXE

comment:3 by speachy, 7 weeks ago

I was able to get the game going under dosbox, enter cheat mode, and warp into scene 604 -- and lo, the onscreen image is corrupted. looks like my install media was damaged but the installer didn't report it. lovely.

I guess we can probably close this.

comment:4 by dreammaster, 7 weeks ago

Owner: set to dreammaster
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.