Opened 2 months ago

Closed 5 weeks ago

Last modified 5 weeks ago

#14955 closed defect (wontfix)

SCI: QFG4: Squid Stone Runes Dial Not Working

Reported by: ArthurWalden Owned by: sluicebox
Priority: high Component: Engine: SCI
Version: Keywords: original squid stone runes
Cc: ArthurWalden Game: Quest for Glory 4

Description

I am using ScummVM version 2.8.0.

In Quest for Glory IV, I am unable to enter the name "Avoozl" into the squid stone runes dial. The main problem is that I cannot enter two "Os" consecutively. Clicking on the same rune a second time just has the letter lit up in red blink without the dial spinning. Also, when I click on some letters the dial sometimes spins to another letter, requiring me to click on the letter again to spin the dial to it.

The SCI bugs log seems to state that this bug was fixed, but now it seems to be recurring.

Please note that the save I am attaching here does NOT include Ashlancer's patch (or any third party software). It is true I have been combining Ashlancer's patch with ScummVM for my current playthrough of QFG4. However, when I ran into this problem, I uninstalled my game and reinstalled without the third party patch. The problem occurred anyway, so this is not due to a conflict.

I am playing the GOG English version of the game.

I am running the game on Windows 10 Home, version 22H2.

Attachments (1)

qfg4-cd-win.001 (44.9 KB ) - added by ArthurWalden 2 months ago.

Download all attachments as: .zip

Change History (5)

by ArthurWalden, 2 months ago

Attachment: qfg4-cd-win.001 added

comment:1 by antoniou79, 2 months ago

I cannot reproduce this issue, ie. not being able to spell AVOOZL with the saved game you provided. When clicking on "O" a second time it blinks a bit and then turns red again, which indicates it was indeed clicked twice. So it does consider the second "O" entered.

I have tested with ScummVM 2.8.0 as well as a fresh dev build of ScummVM 2.9.0git from current (today's) source code (master HEAD).

The "broken dial" (sometimes requiring to click twice on a letter, because the dial won't turn all the way) seems to be a separate bug, and I believe also one that the original game also had.

For reference, this seems to be the original bug report about the issue; sluicebox links to the PR that fixed it in the comments.
https://bugs.scummvm.org/ticket/10965

comment:2 by ArthurWalden, 2 months ago

Actually, I may have been premature in reporting this. After seeing some online comments (including one replying to me on GOG forums about problems with clicking too fast) and doing a little of my own troubleshooting, I concluded the problem I had was that the common advice of clicking the sequence "AVVOOOZZLL" was incorrect by one letter. Specifically, I noticed that the "Z" lit up red after only one click. The correct sequence as the game stands now is "AVVOOOZLL," one less "Z."

I have now completed the game (combining ScummVM and Ashlancer's patch, incidentally). Thank you for working on it, though.

(I have also noted that you get no puzzle points for opening the squid stone, despite CyricZ claiming the action was worth 6 points. This aspect almost certainly goes back to Sierra, however. It may be a difference from the floppy version, though I am not sure.)

comment:3 by bluegr, 5 weeks ago

Owner: set to bluegr
Resolution: duplicate
Status: newclosed

Closing as duplicate of bug #10965

comment:4 by sluicebox, 5 weeks ago

Keywords: original added
Owner: changed from bluegr to sluicebox
Resolution: duplicatewontfix

This is all covered in the patch notes for #10965: https://github.com/scummvm/scummvm/commit/67a29ad5b361a0752f40c432d1ab37ac7701d5b6 , but it can be confusing.

The dial spins in ScummVM just like it does in the original. The CD version spins differently from the floppy version because Sierra upgraded the underlying Cycler scripts in the CD version to significantly different versions with different behaviors. This is the cause of many subtle CD differences and is not something that can be script patched or overridden. There is no line or two of code to alter; entire core scripts were rewritten with different structures and rules.

Separate from that, the dial has a script bug in all versions where clicking too quickly prevents the letters from registering, even though they light up, causing fast players to have their answer rejected. We fixed that script bug.

Changing this to wontfix because it's not a duplicate of #10965, that's the "click too quickly" script bug that we fixed. This is original spin behavior that can't be changed even if we wanted to, and unlike the other bug, it doesn't prevent solving the puzzle. It's true that the puzzle spins in a more pleasant way in the floppy version, but unfortunately that's just how this game works, and you can find other instances including ego walking less smoothly in CD.

Note: See TracTickets for help on using tickets.