Opened 16 years ago

Closed 16 years ago

#1491 closed defect (worksforme)

OSX: CDs cannot be changed (in COMI)

Reported by: SF/simonbrueckner Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

The system seems to lock the CD in the CD-Rom drive so that it
cannot be changed when gameplay requires the second disc.
The only choice is to leave the game (gcc on OSX).

This happened with the german version.

Build of CVS-version 20040223.

Ticket imported from: #903217. Ticket imported from: bugs/1491.

Change History (9)

comment:1 by fingolfin, 16 years ago

This used to work fine, however, with the new imuse etc. it's very well
possible that something still has a file open on the CD media, in which
case CD changing indeed won't work.

In the meantime, you can copy the data files to the HD as a workaround
for the problem.

comment:2 by SF/simonbrueckner, 16 years ago

Thanks for the hint, fingolfin!
I knew this bug should have been corrected (was in the Readme or
something), but thought it might be an OS-specific issue because OS X
sometimes likes to lockup CDs.

But it reminds me of something else: Didn't the original COMI have an
autosave feature before or after cutscenes? That would propably
something precious!

comment:3 by fingolfin, 16 years ago

Summary: CDs cannot be changed on OS XOSX: CDs cannot be changed (in COMI)

comment:4 by fingolfin, 16 years ago

I never played the original COMI, so I have no idea about that auto save
feature. But please use the feature request tracker if you have FRs :-)

comment:5 by fingolfin, 16 years ago

I can't reproduce this using boot param 460 (which puts me right before
the end of act II). So please attach a relevant savegame, we can only fix
bugs we can reproduce. Thanks!

comment:6 by fingolfin, 16 years ago

Status: newpending

comment:7 by SF/simonbrueckner, 16 years ago

I am sorry but the savegame i have is produced with a self compiled
version of an early daily build and does not seem to be compatible with
the snapshots that can be downloaded. Perhaps this bug was due to the
fact that i did compile scummvm by myself ...

comment:8 by SF/simonbrueckner, 16 years ago

Status: pendingnew

comment:9 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.