Opened 5 months ago

Closed 5 months ago

#14852 closed defect (fixed)

ULTIMA8: Unexpected jumping sometimes occurs on left click.

Reported by: OMGPizzaGuy Owned by: OMGPizzaGuy
Priority: normal Component: Engine: Ultima
Version: Keywords:
Cc: Game: Ultima VIII: Pagan

Description

Version 2.8.0 - This is more obvious when using gamepad or keyboard movement options. A left click can be interpreted as a jump even though right mouse button is not being held or clicked. This can very easily cause a player to jump into water or lava, resulting in death.

The root cause appears to be a check for any movement or holding the "step" button and left clicking. This might be best isolated to "MOVE_MOUSE_DIRECTION"

Change History (1)

comment:1 by OMGPizzaGuy, 5 months ago

Owner: set to OMGPizzaGuy
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.