Opened 5 months ago

Closed 4 months ago

#14845 closed defect (fixed)

SCUMM: DIG: Conversation is stuck mid-cutscene and the game appears soft-locked

Reported by: antoniou79 Owned by: athrxx
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: The Dig

Description

This is tested on Windows with ScummVM 2.8.0 and ScummVM 2.9.0git (from recent master), and on Android ScummVM 2.8.0 with the GOG version of The Dig (English).

Early in the game, after the explosives are detonated on Attila, the three protagonists descent in a cave. There's an odd projection there, where Low can use his zero-G digger tool. If he does, the game gets stuck (at least seemingly).

Steps to reproduce from provided save file:

  • Use zero-G digger on odd projection
  • Do not skip the cutscene that follows (dialogue lines may still be skipped with the '.' key; that does not seem to affect the bug)

Result:

  • When Low calls Brink to take a closer look, Maggie will position herself closer, but Brink does not move, and the cutscene appears stuck. The game is not frozen. Music and animations still play, but nothing happens and of course the player has no control.

What should happen:

  • Brink should move closer as well, and there's quite a bit of remaining dialogue before the cutscene ends.

The workaround to give back control to the player is to press Esc.

Attachments (1)

dig.s09 (22.8 KB ) - added by antoniou79 5 months ago.

Download all attachments as: .zip

Change History (5)

by antoniou79, 5 months ago

Attachment: dig.s09 added

comment:1 by antoniou79, 5 months ago

Also note that the issue is not present on ScummVM 2.7.1

comment:2 by athrxx, 4 months ago

Owner: set to athrxx
Resolution: fixed
Status: newpending

I have made a fix. Please check if it works for you.

in reply to:  2 comment:3 by antoniou79, 4 months ago

Replying to athrxx:

I have made a fix. Please check if it works for you.

Yes, works fine here too.
Thank you for the fix.

comment:4 by athrxx, 4 months ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.