Opened 5 months ago

Closed 4 months ago

Last modified 4 months ago

#14837 closed defect (fixed)

BACKENDS: 3DS: AGS games not starting on daily dev builds

Reported by: Chuckaluphagus Owned by: lephilousophe
Priority: normal Component: Port: 3DS
Version: Keywords: AGS
Cc: Game:

Description

ScummVM version
ScummVM latest Branch Master (2024-01-10), https://buildbot.scummvm.org/dailybuilds/master/3ds-master-bb45f575.zip

Bug details
I copied "scummvm.3dsx" to "/3ds" on my SD card. I installed The Blackwell Legacy via Steam, then copied the following files to "/ScummVM Games/Blackwell Legacy":

audio.vox
Blackwell Legacy.ags
speech.vox

I ran ScummVM via the Homebrew Launcher, then added the game to my library. When I tapped "Start", I received the error message, "Could not find any engine capable of running the selected game"

Language of game
English

Version of game
Steam, updated 2024-01-08

Your OS, including version and device if appropriate
New Nintendo 3DS XL, Sys. 11.17.0-50U, Luma 13.0.2

Attach a save game if possible
No save game

If this bug only occurred recently, please note the last version without the bug, and the first version including the bug.
If I go through the same steps with ScummVM 2.70, the game will load. The in-game graphics are distorted and unusable (they're only partially visible, and squashed to the left side of the screens), and I can't seem to do anything other than exit back to the ScummVM launcher.

Change History (5)

comment:1 by Chuckaluphagus, 5 months ago

Oh, and please let me know if there's anything you'd like me to test, or try out. Thank you for your time.

comment:2 by Chuckaluphagus, 5 months ago

Summary: Blackwell Legacy crashes on 3DS portBlackwell Legacy fails on 3DS port

comment:3 by tag2015, 5 months ago

Keywords: AGS added; 3DS Blackwell ags wadjet removed
Summary: Blackwell Legacy fails on 3DS portBACKENDS: 3DS: AGS games not starting on daily dev builds

Hi, thanks for the report. I changed the title because this seems to be a generalized problem, I tried another game (Maniac Mansion Deluxe) and it shows the same error.
There's also an issue in GUI, the per-game options should show the language combobox and the override checkboxes but these don't appear in the 3DS port.

comment:4 by BallM4788, 4 months ago

Owner: set to BallM4788
Resolution: fixed
Status: newclosed

Marking this ticket as resolved, as a commit has been introduced that fixes both this bug and ticket:14905.

comment:5 by bluegr, 4 months ago

Owner: changed from BallM4788 to lephilousophe
Note: See TracTickets for help on using tickets.