Opened 5 months ago

Closed 5 months ago

#14820 closed defect (fixed)

SWORD1: Speech volume setting maxc value is out of bound

Reported by: Yalefeuv Owned by: AndywinXp
Priority: normal Component: Engine: Sword1
Version: Keywords: audio speech
Cc: Game: Broken Sword 1

Description (last modified by Yalefeuv)

OS: Win7 x64
ScummVM version: 2.8.0 also confirmed on daily build d40e408fc8a977d8ba44c5684459a315eab8b974
Game: Broken sword 1 / PC

Speech volume setting max value is out of bound and cause mute

Attachments (3)

log.txt (4.2 KB ) - added by Yalefeuv 5 months ago.
scummvm.ini (12.0 KB ) - added by Yalefeuv 5 months ago.
old ini
scummvm.2.ini (696 bytes ) - added by Yalefeuv 5 months ago.
new ini (work)

Download all attachments as: .zip

Change History (21)

comment:1 by Yalefeuv, 5 months ago

Description: modified (diff)
Priority: normalhigh

comment:2 by AndywinXp, 5 months ago

Hi! Thanks for the report; can you provide some info about your version? It would be useful to see the complete list of files for your game. Also, please try running ScummVM with debug flags

scummvm.exe -d5

and let me know if, when playing the game, there are any debug warnings concerning the audio engine.

by Yalefeuv, 5 months ago

Attachment: log.txt added

comment:3 by AndywinXp, 5 months ago

Everything looks normal there... Is this copy from GOG? Steam? CDs?

comment:4 by Yalefeuv, 5 months ago

Attached a part of the output with the -d5.

in reply to:  3 comment:5 by Yalefeuv, 5 months ago

Replying to AndywinXp:

Everything looks normal there... Is this copy from GOG? Steam? CDs?

The copy is from CDs. Just tested with the steam dlc (original version) and results are the same.

comment:6 by Yalefeuv, 5 months ago

Keywords: french removed
Summary: Broken sword 1 French speeches audio missingBroken sword 1 speeches audio missing

Tested whith the steam fr & uk versions. Same results

Last edited 5 months ago by Yalefeuv (previous) (diff)

comment:7 by AndywinXp, 5 months ago

Keywords: french added
Summary: Broken sword 1 speeches audio missingBroken sword 1 French speeches audio missing

Thanks for verifying. I also tried several Steam localizations and I can't reproduce it unfortunately, but we can try something else:
1) Upload here your scummvm.ini (I believe you can write %appdata% on a Windows Explorer address bar and then find it from there), so I can take a look at it to see if there is something wrong with it
2) Try placing an empty scummvm.ini file near your ScummVM executable, re-add the game, launch it, and tell me how it goes

comment:8 by AndywinXp, 5 months ago

Summary: Broken sword 1 French speeches audio missingSWORD1: Speech is not working

by Yalefeuv, 5 months ago

Attachment: scummvm.ini added

old ini

comment:9 by Yalefeuv, 5 months ago

Resetting the ini file worked

by Yalefeuv, 5 months ago

Attachment: scummvm.2.ini added

new ini (work)

comment:10 by Yalefeuv, 5 months ago

Thanks for your help.

comment:11 by AndywinXp, 5 months ago

Thanks for your patience, I'm glad we could sort this out!

Apparently, the issue was that your old ini file had this line near the beginning:

speech_volume=256

This was interpreted by the game as an out of bound value (it had to be in the range 0-255). Bringing that down to, say, 192 should work fine.

If you don't want to touch that general setting, you can go in the in-game settings and bring the speech level to a correct value.

comment:12 by AndywinXp, 5 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed

comment:13 by Yalefeuv, 5 months ago

In game setting speech volume is buggy. The max volume is an out of bound value.

comment:14 by Yalefeuv, 5 months ago

Description: modified (diff)
Resolution: fixed
Status: closednew
Summary: SWORD1: Speech is not workingSWORD1: Speech volume setting maxc value is out of bound

comment:15 by Yalefeuv, 5 months ago

Priority: highnormal

comment:16 by Yalefeuv, 5 months ago

Keywords: french removed

comment:17 by AndywinXp, 5 months ago

Thanks, bug fixed on master and future 2.8.x with commit https://github.com/scummvm/scummvm/commit/a1683df07219975a7b1cf6740e54df06deac9493

comment:18 by AndywinXp, 5 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.