Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#14798 closed defect (invalid)

SCI: PQ2 for Atari ST fails to launch

Reported by: TrivialBalderdash Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords:
Cc: TrivialBalderdash Game: Police Quest 2

Description

Atari ST version of Police Quest 2 fails to launch with the error shown below.

User picked target 'pq2-st' (engine ID 'sci', game ID 'pq2')...
   Looking for a plugin supporting this target... SCI [all games]
Running Police Quest II: The Vengeance (Atari ST/English)
resource.001: 77f02def3094af804fd2371db25b7100, 506563 bytes.
resource.002: 77f02def3094af804fd2371db25b7100, 541261 bytes.
resource.003: 77f02def3094af804fd2371db25b7100, 587511 bytes.
resource.map: 8e1161c684b342742d30f938a4839a4b, 4518 bytes.
WARNING: Volume version not detected, but map version has been detected. Setting volume version to map version!
WARNING: Error 6 occurred while reading view.19 from resource file RESOURCE.001: Unknown compression method!
WARNING: resMan: Failed to read view.19!
WARNING: Error 6 occurred while reading view.13 from resource file RESOURCE.001: Unknown compression method!
WARNING: resMan: Failed to read view.13!
WARNING: Error 6 occurred while reading view.19 from resource file RESOURCE.001: Unknown compression method!
WARNING: resMan: Failed to read view.19!
WARNING: Error 6 occurred while reading vocab.1541 from resource file RESOURCE.001: Unknown compression method!
WARNING: resMan: Failed to read vocab.1541!
WARNING: Error 6 occurred while reading view.19 from resource file RESOURCE.001: Unknown compression method!
WARNING: resMan: Failed to read view.19!
[pq2-st]: Script 0 not found!

I posted some additional information here -> https://forums.scummvm.org/viewtopic.php?t=16987

If helpful, here is the information from the .qa file on the disk:

    Police Quest Two
      by Jim Walls

   Atari ST Conversion
	   by Corey Cole

 Version Number 1.001.006
  (double-sided version)
  Interpreter: 1.001.009
     January 16, 1989
         1:30 p.m.

This behavior is seen on 2.2.0, 2.7.0, 2.8.0 for Linux (Raspberry Pi) and Intel/Mac running 13.6.3.

Thanks for looking into this!

Change History (4)

comment:1 by sluicebox, 5 months ago

Hello! You have corrupt game files. I have that version and it works with no errors. In fact, the resource files for those PQ2 Atari ST versions are identical to the DOS versions, so the Atari ST part isn't even relevant.

I see that you've copied these from your own disks (awesome!) but it looks like that's where the problem is. Here's what I've got:

C:\Corpus\pq2-atari-st-1.001.006>md5sum *
1cb029b9f2cf771cedd64c1396c3ba7c *ATARIKBD.DRV
d2a5f7db34c3143789c4176785d7ba07 *ATARISND.DRV
bea12f2d507d715f3064c2eabefbf87f *DESKTOP.INF
2928572ceafaadbc2e568ed4f8850b89 *MT32.DRV
e1dcf78ad1698e6b40f72797842d0ed6 *MUSIC.PRG
fedad9ee54dd7fe65841c522becc0ced *MUSIC.RSC
97c923bd620ac12e7730f954d42ed860 *PQ2_ST.QA
9614dfa9f4611f71acd3e777c72cc486 *RESOURCE.001
c83538eef89e756971736327353ef647 *RESOURCE.002
7e3cfa6bf4977851e7152a563e3aa92a *RESOURCE.003
fd744dd15fa91cfd4ce2a139e6c7096f *RESOURCE.CFG
8e1161c684b342742d30f938a4839a4b *RESOURCE.MAP
fb1f2fa2e35fb2ddbe63c2d8626f11ec *SIERRA.PRG

comment:2 by TrivialBalderdash, 5 months ago

Owner: set to TrivialBalderdash
Resolution: invalid
Status: newclosed

Thank you for the lightning fast response!

Looks like it's just the .001 file. I'll try to copy the disk/file again.

MD5 (ATARIKBD.DRV) = 1cb029b9f2cf771cedd64c1396c3ba7c
MD5 (ATARISND.DRV) = d2a5f7db34c3143789c4176785d7ba07
MD5 (DESKTOP.INF) = 06fa20935ae70955f175b602715d168f
MD5 (MT32.DRV) = 2928572ceafaadbc2e568ed4f8850b89
MD5 (MUSIC.PRG) = e1dcf78ad1698e6b40f72797842d0ed6
MD5 (MUSIC.RSC) = fedad9ee54dd7fe65841c522becc0ced
MD5 (PQ2_ST.QA) = 97c923bd620ac12e7730f954d42ed860
MD5 (RESOURCE.001) = 5f0614bc673d636ac929f6197fee692d
MD5 (RESOURCE.002) = c83538eef89e756971736327353ef647
MD5 (RESOURCE.003) = 7e3cfa6bf4977851e7152a563e3aa92a
MD5 (RESOURCE.CFG) = fd744dd15fa91cfd4ce2a139e6c7096f
MD5 (RESOURCE.MAP) = 8e1161c684b342742d30f938a4839a4b
MD5 (SIERRA.PRG) = 4968d033e113eb7ade34d7b384d4837a

comment:3 by sluicebox, 5 months ago

Owner: changed from TrivialBalderdash to sluicebox

Great! If you need any help along those lines, feel free to ping me on our discord server

comment:4 by sluicebox, 5 months ago

lol okay to be clear i did not mean to change the ticket owner, but i guess i'm going to "own" that mistake

Note: See TracTickets for help on using tickets.