Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#14795 closed defect (fixed)

TWINE: LBA1: Scenery zoom glitched...

Reported by: mgerhardy Owned by: mgerhardy
Priority: normal Component: Engine: TwinE
Version: Keywords:
Cc: Game: Little Big Adventure

Description (last modified by mgerhardy)

See https://bugs.scummvm.org/ticket/14776 for a few more details.

With the "scenery zoom-on" option it does seem to glitch randomly (the scene I've tested was near the start of the game, outside the prison, when Twinsen gets on the back of the garbage truck)

Attachments (1)

lba-win-de-3.000 (8.9 KB ) - added by mgerhardy 5 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 by mgerhardy, 5 months ago

Description: modified (diff)

comment:2 by mgerhardy, 5 months ago

text from manual:

NO SCENERY ZOOM/SCENERY ZOOM ON: Toggle this option ON/OFF.
When off, the game does not automatically zoom in during key
parts of the story. You can still manually zoom in on objects by
pressing F5.

I doubt we have the F5 key bound

The toggle bool is

_engine->_cfgfile.SceZoom

and the state is in

engine->_redraw->_inSceneryView

It's changed in life script with opcode 0x39 (lZOOM)

comment:3 by mgerhardy, 5 months ago

Description: modified (diff)

comment:4 by mgerhardy, 5 months ago

bug must be in

void Redraw::zoomScreenScale() {
[...]
	g_system->copyRectToScreen(zoomWorkVideoBuffer.getPixels(), zoomWorkVideoBuffer.pitch, 0, 0, zoomWorkVideoBuffer.w, zoomWorkVideoBuffer.h);
	g_system->updateScreen();
}

I suppose this is updating the screen at least twice per frame

comment:5 by mgerhardy, 5 months ago

cff51c8f4bd1a8b8b00b0fb775703de3e703365e added the feature to bind a key to the zoom action. No default binding is given here yet. If you set one, you can quickly reproduce the issue.

comment:6 by mgerhardy, 5 months ago

Owner: set to mgerhardy
Resolution: fixed
Status: newclosed

comment:7 by DjDiabolik, 5 months ago

Are you completely sure the glitch zoom it's fixed on current daily build ?

I'm reach the possibly to buy my personal boat and when i can use it the games use the ZOOM mode until boat exit from current level and screen goes completely in glitch again also at today...

So... currently i can upload my personal savestate because i have this games "installed" at my Brothers home. I can play it only when I go to him.

by mgerhardy, 5 months ago

Attachment: lba-win-de-3.000 added

comment:8 by mgerhardy, 5 months ago

I've tested with the garbage truck and there it works fine - attached a savegame

Note: See TracTickets for help on using tickets.