Opened 5 months ago

Last modified 4 months ago

#14793 new defect

AUDIO: Intro music of DOTT doesn't work anymore on clean config and LINUX+SDL

Reported by: mikrosk Owned by:
Priority: normal Component: Audio
Version: Keywords:
Cc: Game: Day of the Tentacle

Description

Sound effects work but the iconic music is gone.

The commit which broke it was https://github.com/scummvm/scummvm/commit/8bb2afd2.

Tested on Linux + SDL, present in both latest master and 2.8.0.

Change History (8)

comment:1 by mikrosk, 5 months ago

I tested it also with removed scummvm.ini, no change.

comment:3 by elasota, 5 months ago

Does it work if you disable General MIDI in the settings?

comment:4 by mikrosk, 5 months ago

You mean MIDI -> GM device: Don't use General MIDI music? Yes, after changing it to this value from "Use first available" it works.

comment:5 by elasota, 5 months ago

What options are listed under the "GM device" drop-down?

comment:6 by mikrosk, 5 months ago

Don't use General MIDI music
Use first available device
Midi Through [ALSA]
SEQ
Sndio
FluidSynth
TIMidity

comment:7 by AndywinXp, 5 months ago

Component: Engine: SCUMMAudio
Summary: DOTT: Intro music doesn't work anymoreAUDIO: Intro music of DOTT doesn't work anymore on clean config and LINUX+SDL

comment:8 by rsn8887, 4 months ago

A similar problem happens on Vita/Switch, see here: https://forums.scummvm.org/viewtopic.php?t=17022

On those platforms I fixed it for the future by defaulting GM Device Config entry to "null".

Note: See TracTickets for help on using tickets.