Opened 5 months ago

Closed 5 months ago

#14786 closed defect (fixed)

MTROPOLIS: Muppet Treasure Island crashes to desktop

Reported by: TrivialBalderdash Owned by: elasota
Priority: high Component: Engine: mTropolis
Version: Keywords:
Cc: TrivialBalderdash Game: Muppet Treasure Island

Description

Trying to start a new game for Muppet Treasure Island at the end of the intro crashes to desktop. If you skip the sequence by pressing the space bar, the result are the same.

Running Windows/Mac 3-CD version (Windows files) on 2.8.0 build on Intel MacOS 13.6.3.

The terminal tells me this (same as scummvm.log):

User picked target 'mti-win' (engine ID 'mtropolis', game ID 'mti')...
   Looking for a plugin supporting this target... mTropolis
Running Muppet Treasure Island (Windows/English)
MTI1.MPL: cd0e1cd198fa2971371f42bb92b44972, 28500187 bytes.
WARNING: Couldn't load resources from PE file 'GROUP3.R95'!
WARNING: Couldn't load resources from PE file 'MTIKIT.R95'!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Unknown plug-in value type 6d!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Couldn't resolve static guid '2ca852' with name 'hensonMuppetList'!
WARNING: Loading object reference lists from data is not implemented!
WARNING: Loading object reference lists from data is not implemented!
zsh: segmentation fault

I tried copying all files into the same directory (having seen the *.R95 errors above), but there was no change.

Change History (4)

comment:1 by tag2015, 5 months ago

I can't reproduce the problem on Windows. I wonder if it may be a Mac related issue

comment:2 by elasota, 5 months ago

Owner: set to elasota
Resolution: assigned
Status: newpending

comment:3 by elasota, 5 months ago

Can you run this with -d 4 in the command line to report more information in the log?

comment:4 by elasota, 5 months ago

Resolution: assignedfixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.