Opened 6 months ago

Closed 5 months ago

#14780 closed defect (fixed)

FREESCAPE: Keep pressing the on-screen arrows on Freescape games will not move the player

Reported by: neuromancer Owned by: neuromancer
Priority: normal Component: Port: iOS
Version: Keywords:
Cc: Game: Driller

Description

When using the on-screen controller (dpad mode), pressing the "arrows" once will move the player correctly. However, keeping pressing them will not work. This should work the same the keyboard that will produce a "continuous" movement.

Change History (2)

comment:1 by neuromancer, 6 months ago

Summary: Keep pressing the on-screen arrows on Freescape games will not move the playerFREESCAPE: Keep pressing the on-screen arrows on Freescape games will not move the player

Actually, this is a freescape specific bug, since it needs to be implemented by every engine. It should be already solved in https://github.com/scummvm/scummvm/commit/89b95438155be205a7dc688ee8e928dd25fe9ff7#diff-bb201e98ff48a30749ce9cf1e94b3e482c4f14e311101ee6773dcd8cd1c812d6R166, but I need to wait for the next ios build to verify it.

comment:2 by neuromancer, 5 months ago

Owner: set to neuromancer
Resolution: fixed
Status: newclosed

Confirmed, this is fixed already

Note: See TracTickets for help on using tickets.