Opened 5 months ago

Closed 2 months ago

#14775 closed defect (fixed)

Unknown game variant for director (Wrath of the Gods)

Reported by: MaddTheSane Owned by: tag2015
Priority: normal Component: Engine: Director
Version: Keywords: unknown-game
Cc: Game:

Description

The game in 'Wrath' seems to be an unknown game variant.

Please report the following data to the ScummVM team at https://bugs.scummvm.org/ along with the name of the game you tried to add and its version, language, etc.:

Matched game IDs for the director engine: wrath-mac

{"Wrath of the Gods", 0, "d41d8cd98f00b204e9800998ecf8427e", 0},

Version as reported by Get Info in Sonoma:
3.1.3, Copyright © 1985-93 by Macromedia, Inc.
MacroMind Player 3.1.3

Looking at the console, it seems to be missing a LINGO.INI file.

Attachments (1)

wrathfs.txt (11.0 KB ) - added by MaddTheSane 5 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 by tag2015, 5 months ago

The file shouldn't be zero-sized.
Did you process the disc image using Dumper Companion?
https://www.scummvm.org/dumper-companion

comment:2 by MaddTheSane, 5 months ago

No, I just copied it from a Mac install.

by MaddTheSane, 5 months ago

Attachment: wrathfs.txt added

comment:3 by MaddTheSane, 5 months ago

Looking at the CD (via HFS), it also lacks the LINGO.INI file.
I just attached what the file system looks like when using find on the root directory of the CD.

comment:4 by MaddTheSane, 5 months ago

My guess is that the starting data is stored in the "Wrath of the Gods" executables (there's multiple for different memory sizes) in STR# ID 0 ("Wrath of the Gods:Wrath:00.Go")

Also, sorry for the double-post.

comment:5 by tag2015, 5 months ago

Please, since you have the CD:
1- just create a disc image using Disk Utility (or Toast or any other common software)
2- use Dumper Companion on it (it'll generate a .zip to download)
3- Extract the zip and add the resulting folder to ScummVM

comment:6 by MaddTheSane, 5 months ago

Yep, that did it.
I am curios why that worked, though. Does ScummVM not check the resource fork on macOS?

comment:7 by tag2015, 2 months ago

I have not been using OSX/macOS for some time, but I think that support for HFS (not HFS+) was dropped some time ago. It's more likely that the original game install was somehow corrupted when you moved it to Sonora.

Anyway if you want more info you can ask on the forum or the Director channel on Discord https://discord.com/channels/581224060529148060/636495083935629325

comment:8 by tag2015, 2 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.