Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#14754 closed defect (fixed)

AGS: Quest for Glory II Remake: character can't be imported to later games due to file prefix

Reported by: lwcorp Owned by: tag2015
Priority: normal Component: Engine: AGS
Version: Keywords: import
Cc: Game: Quest for Glory 2

Description (last modified by lwcorp)

This game is a remake, so you shouldn't expect other decades old games in the series to add special support for it. Unfortunately, ScummVM did just that by prefixing its character endgame exports with qfg2agdi- (e.g. qfg2agdi-test.sav) instead of keeping the original form qfg2- (e.g. qfg2-test.sav). This is a pure ScummVM decision, as in the original AGS engine there was no prefix at all (if you called it test, then it would be just test.sav), which is of course no good either, but still less confusing, as adding a manual prefix is clearer than renaming an existing one.

Steps to reproduce
1) Finish the game
2) Supply a filename
3) Try to import it to either QFG3 or QFG4

Expected result
In both QFG3 and QFG4, the import is shown, clickable and works successfully

Actual outcome
In both QFG3 and QFG4, The import is not shown and thus not even testable

Additional info
The solution should be to either:
1) Change the AGS implementation to using the original form qfg2-
2) Change both QFG3 and QFG4 to respect the qfg2agdi- prefix just like the qfg2- prefix

Obviously 1 will be quicker, while 2 will be more organized and logical.

P.S.
I've included a savegame, but if you have access to the game's internal debug mode (or find a way to do it from ScummVM's debugger), it might be easier to just skip to room 253 and be immediately presented with a save character box.

Attachments (1)

qfg2agdi.001 (910.9 KB ) - added by lwcorp 6 months ago.
Savegame right before finishing the game (the last place with a save slot). Finish casting Force Bolt between the left most candles and finish the game to be able to save the character

Download all attachments as: .zip

Change History (5)

by lwcorp, 6 months ago

Attachment: qfg2agdi.001 added

Savegame right before finishing the game (the last place with a save slot). Finish casting Force Bolt between the left most candles and finish the game to be able to save the character

comment:1 by lwcorp, 6 months ago

Description: modified (diff)

comment:2 by lwcorp, 6 months ago

Description: modified (diff)

in reply to:  description comment:3 by tag2015, 6 months ago

Replying to lwcorp:

This game is a remake, so you shouldn't expect other decades old games in the series to add special support for it. Unfortunately, ScummVM did just that by prefixing its character endgame exports with qfg2agdi-

AFAIK, we haven't done anything specific for this game. In general, files generated by the games (for the AGS engine at least) are automatically prefixed with the gameid to avoid overwriting other files, since the savedir is shared.

The solution should be to either:
1) Change the AGS implementation to using the original form qfg2-
2) Change both QFG3 and QFG4 to respect the qfg2agdi- prefix just like the qfg2- prefix

Opened PR 5538

comment:4 by bluegr, 6 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed

The PR has been approved, so this is fixed now (with solution 2)

Last edited 6 months ago by bluegr (previous) (diff)
Note: See TracTickets for help on using tickets.