Opened 5 months ago

Last modified 4 months ago

#14730 pending defect (fixed)

AGS: Whispers of a Machine crashes on Day 3

Reported by: noblonski Owned by: tag2015
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

hello,

this happens on ios & windows.
after trying to grab the scarf and the pole breaks on day 3, the game crashes.

Assertion failed: _spriteData[sprnum].IsAssetSprite(), file /data/src/engines/ags/shared/ac/sprite_cache.cpp, line 241

Attachments (1)

Whispers.rar (1.8 MB ) - added by noblonski 4 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 by tag2015, 5 months ago

Thanks for the report. This game uses a fork of the AGS engine, which most likely does not include these sanity checks.
This is not a recent regression, probably the culprit is this commit
https://github.com/scummvm/scummvm/commit/fad62e8cef33f52be6502b7e3499631c0a712348
but it was not noticed till now because Whispers of a Machine had other issues (and nobody played it this far)

I'll do some tests and eventually open a bugreport on their tracker

comment:2 by tag2015, 5 months ago

Summary: Whispers of a Machine crashes on Day 3AGS: Whispers of a Machine crashes on Day 3

comment:3 by tag2015, 4 months ago

Could you provide a save please?
If you didn't use the scummvm menu, this game autosaves in slots 100-104 so saves should be named whispersofamachine.10[0-4]

comment:4 by noblonski, 4 months ago

hello,

here are the save files. the load function only appears after selecting start game.
simply go to the right and pick up the scarf. after the cutscene the game crashes.
https://www.dropbox.com/scl/fi/rtj1pvvkntrnoymdjpsc1/Whispers.rar?rlkey=wqbtf89b1bl2q5b8r61wwh369&dl=0

hope this helps.

cheers
phil

by noblonski, 4 months ago

Attachment: Whispers.rar added

comment:5 by tag2015, 4 months ago

Hi, I committed a fix, and played till the end of the game. Could you try with tomorrow's daily build? Also, it would be amazing if you could comlpete another playthrough using the other paths/augmentations. Thanks!

Last edited 4 months ago by tag2015 (previous) (diff)

comment:6 by tag2015, 4 months ago

Owner: set to tag2015
Resolution: fixed
Status: newpending

comment:7 by noblonski, 4 months ago

good to hear!
thanks a lot.

yes, i will start from the beginning tomorrow
and keep you posted.

cheers
phil

Note: See TracTickets for help on using tickets.