Opened 15 years ago

Closed 15 years ago

Last modified 9 months ago

#1473 closed defect (invalid)

OS X: Add Game dialog stays on top

Reported by: SF/donaciano11 Owned by: fingolfin
Priority: normal Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

I keep my games on an external firewire disk, so upon going to
open a game I noticed it wasn't turned on yet. So I flip the switch
and wait for the drives to pop up in the window, and I go back to
Safari to do other things. However the Add Game dialog box stays
in front no matter which program you go into. Would be nice if it
would just go in the background like a nice OS X program and not
block my other windows. Also, I'd LOOOVE to be able to use
Command-H to hide instead of only being able to use the menu.

Minor lil gripes, SCUMMVM is INCREDIBLE :-D Thanks for all your
hard work guys and keep at it.

Ticket imported from: #900572. Ticket imported from: bugs/1473.

Change History (3)

comment:1 Changed 15 years ago by fingolfin

The "add-dialog-always-on-top" thing isn't a bug, it is intended behaviour.
Otherwise the dialog will be invisible when running in full screen mode.
I would make this conditional so that it is only used when actually in
fullscreen mode, but due to limitations in the SDL backend (which we use
to run ScummVM on Mac OS X) this is currently not possible; however,
we are working to fix this for future versions.

As for the Cmd-H thing, this would require adding a Mac OS X specific
hack to the backend. File a feature request for it if you like, and we can
consider it for a future release.

comment:2 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: invalid
Status: newclosed

comment:3 Changed 9 months ago by digitall

Component: --Unset--Port: Mac OS X
Note: See TracTickets for help on using tickets.