Opened 7 months ago

Closed 6 months ago

#14687 closed defect (fixed)

ULTIMA6: Game crashes

Reported by: bliznik Owned by: PushmePullyu
Priority: high Component: Engine: Ultima
Version: Keywords:
Cc: Game: Ultima VI: The False Prophet

Description

Using the latest development build 2.8.0git9207-g77dc8caa9f0 (Nov 8 2023 15:46:41)

Starting the game crashes.

Attached is the verbose crash log.

Attachments (2)

scummvm.log (315 bytes ) - added by bliznik 7 months ago.
scummvm.2.log (35.3 KB ) - added by bliznik 7 months ago.

Download all attachments as: .zip

Change History (7)

by bliznik, 7 months ago

Attachment: scummvm.log added

comment:1 by mduggan, 7 months ago

There's nothing in the attached log except for ScummVM startup.. did you attach the right file? :)

comment:2 by bliznik, 7 months ago

Oh, I see...I must not have hit refresh before uploading last time. Here it is again, this time with the most recent daily build from Nov 13

Last edited 7 months ago by bliznik (previous) (diff)

by bliznik, 7 months ago

Attachment: scummvm.2.log added

comment:3 by sev-, 6 months ago

Would be nice to get fixed before 2.8.0 release

comment:4 by PushmePullyu, 6 months ago

Thanks for the report! It looks like I broke roof loading/drawing in commit c4970c95dc48fdf38891cec3740ccf98dfd090f9 "Fix crash in GUI on surface blit".

PR with fix is here: https://github.com/scummvm/scummvm/pull/5441

If this is indeed the cause of your crash, a possible workaround is disabling roofs in scummvm.ini.
The key for both [ultima6] and [ultima6_enh] is

ultima6/roof_mode=no

comment:5 by mduggan, 6 months ago

Owner: set to PushmePullyu
Resolution: fixed
Status: newclosed

Fix is now merged, thanks again for reporting.

Note: See TracTickets for help on using tickets.