Opened 6 months ago

Closed 5 months ago

#14682 closed defect (fixed)

NANCY: SKC: Crash when talking to Connie

Reported by: raziel- Owned by: fracturehill
Priority: normal Component: Engine: Nancy
Version: Keywords:
Cc: Game: Nancy Drew: Secrets Can Kill

Description

ScummVM 2.8.0git (Oct 29 2023 09:28:43)
Using SDL backend with SDL 2.28.4
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 MikMod Theora VPX AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) ENet SDL2 TinyGL OpenGL (with shaders)

Talking to Connie in the school will make the game crash.

Click on her from the savegame, she will finish her line:
"Hi, i'm Connie. You're not from around here, are you?"
and after that i get a warning on console
"WARNING: Frame 51 doesn't exist!"
followed by a crash (see log)

Running Nancy Drew: Secrets Can Kill (Windows/English)
ciftree.dat: 9f89e0b53717515ae0eb82d14ffe0e88, 4317962 bytes.

AmigaOS4 - PPC - BE
gcc (adtools build 11.3.0) 11.3.0

Attachments (2)

Crashlog_ScummVM_2023-10-30_14-20-22.txt (42.2 KB ) - added by raziel- 6 months ago.
nancy1.003 (17.0 KB ) - added by raziel- 6 months ago.

Download all attachments as: .zip

Change History (5)

by raziel-, 6 months ago

Attachment: nancy1.003 added

comment:1 by fracturehill, 5 months ago

Oh, this is an interesting one - I cannot reproduce this on my end, but my copy of the game is from a later release than yours, so it seems the devs patched this particular issue at some point. I've pushed a fix to master, hopefully everything works correctly now.

comment:2 by raziel-, 5 months ago

Confirmed fixed

Thanks a lot :-)

comment:3 by fracturehill, 5 months ago

Owner: set to fracturehill
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.