Opened 15 years ago

Closed 15 years ago

#1468 closed defect (fixed)

FT: Computers' Text Drawn Incorrectly

Reported by: SF/darkshineknight Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Hi,
When you are using a computer in Full Throttle (in
the Airplane and the Semi), the text disappears, covers
up other options and performs other erratic things. The
upper text should remain constant, and "This vehicle
has been stolen..." should flash. I have attached a
savegame outside the Semi. Get in, click the screen,
and try "Main Menu", "Defence Menu", "Detach Trailer"
to see what it does.

Thanks

Version: Feb 16 2004 11:24:04 Win32 CVS
Game: Full Throttle, English
MD5: 60ba818dc3bede86d40357e3913f8505 ft.la0

Ticket imported from: #899323. Ticket imported from: bugs/1468.

Attachments (1)

ft.s04 (9.2 KB) - added by SF/darkshineknight 15 years ago.
Save Outside Semi

Download all attachments as: .zip

Change History (6)

Changed 15 years ago by SF/darkshineknight

Attachment: ft.s04 added

Save Outside Semi

comment:1 Changed 15 years ago by sev-

apparently the bug deals with layers priority.

comment:2 Changed 15 years ago by fingolfin

Still occurs with latest CVS.

comment:3 Changed 15 years ago by Kirben

Owner: set to Kirben

comment:4 Changed 15 years ago by Kirben

Resolution: fixed
Status: newclosed

comment:5 Changed 15 years ago by Kirben

Full Throttle handle verbs differently to earlier games, which is
the cause of this bug and other issues.
The original FT always redraws verbs in main loop.
The original FT doesn't restore verb backgrounds manually
when drawing verbs, or use verbs.bkcolor at all. In ScummVM
case, it would never call restoreVerbBG() or verbMouseOver().

I added needed changes to ScummVM CVS, trying to change
as little as possible.

Note: See TracTickets for help on using tickets.