Opened 4 months ago

Closed 2 months ago

#14667 closed defect (invalid)

SWORD1: Unknown game variant for sword1

Reported by: holaoh Owned by: sev-
Priority: high Component: Engine: Sword1
Version: Keywords: unknown-game sword1
Cc: Game: Broken Sword 1

Description

The game in 'Les chevaliers de Baphomet\' seems to be an unknown game variant.

Please report the following data to the ScummVM team at https://bugs.scummvm.org/ along with the name of the game you tried to add and its version, language, etc.:

Matched game IDs for the sword1 engine: sword1-win-pl

{"clusters/scripts.clu", 0, "72b10193714e8c6e4daca51791c0db0c", 1088372},
{"clusters/swordres.rif", 0, "665b7ed64c13013ec4a8bcd101a1e862", 59788},
{"clusters/text.clu", 0, "76f93f5feecc8915435105478f3c6615", 3188750},
{"intro.dxa", 0, "e27cd33593c08b66e8d20fbc40938789", 7566972},

Attachments (1)

LIST.TXT (16.2 KB ) - added by holaoh 3 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 by holaoh, 4 months ago

My french version of broken sword 1 worked very well with previous version of scummvm but since the last one I can't detect it !

comment:2 by AndywinXp, 4 months ago

Hi! Where did you get this copy and what is the complete file list for the two CDs?

comment:3 by AndywinXp, 4 months ago

Any news?

comment:4 by tag2015, 4 months ago

Summary: Unknown game variant for sword1SWORD1: Unknown game variant for sword1

comment:5 by sev-, 3 months ago

We need at least the recursive directory list in order to understand that this is not a modified version.

Could you please provide it?

Would be nice to get fixed before 2.8.0 release

comment:6 by holaoh, 3 months ago

It's my original copy from 1996 big box PC french version with 2 CD.
In the first cd there are this directories:
CLuster
DirectX
Install
Music
Smackshi
Smackslo
speech

comment:7 by sev-, 3 months ago

Thank you, however, we need a recursive list, e.g. output for "DIR /S". You may write "DIR /S >LIST.TXT" and that will redirect the output to LIST.TXT which you can then attach to this report.

by holaoh, 3 months ago

Attachment: LIST.TXT added

comment:8 by holaoh, 3 months ago

Is it good ?

comment:9 by AndywinXp, 3 months ago

It seems that the issue is that you have compressed video files, this is not the layout of the original CDs. Try re-copying the files from the discs.

comment:10 by lotharsm, 3 months ago

Just a quick heads up - did you try to copy the files again from the original CDs so we can check this further?

comment:11 by sev-, 2 months ago

Owner: set to sev-
Resolution: invalid
Status: newclosed

@holaoh This is good, thank you very much for providing it.

It confirms that your copy is not original, because the files in SMACKSHI directory are DXA files compressed in 2007, they could not be on your original CD.

What you need is to re-copy the SMACKSHI directory over again from your CDs and that will solve the issue.

We are not supporting mix-in versions like this one anymore. I know, it could be inconvenient, but we need to do it for easier compatibility.

Note: See TracTickets for help on using tickets.