Opened 8 months ago

Closed 7 months ago

#14637 closed defect (fixed)

AGS: Pleurghburg: Dark Ages crashes on startup

Reported by: Arjak89 Owned by: tag2015
Priority: normal Component: Engine: AGS
Version: Keywords: ags crash
Cc: Game:

Description

When starting Pleurghburg: Dark Ages, the game loads the status bar, freezes for a few seconds, then ScummVM crashes back to desktop.

ScummVM version: 2.7.1
Game Version: 1.3 (English)
OS: Windows 10 22H2 19045.3448

Log:

[2023-09-21 17:46:12] Running Pleurghburg: Dark Ages (English)
[2023-09-21 17:46:12] Pleurgh.exe: 9cf51833e787cc919837d9a8bd8fc14c, 11555983 bytes.
[2023-09-21 17:46:12] WARNING: TODO: SetCurrentDirectory: C:/GASPOP software/Pleurghburg/!
[2023-09-21 17:46:13] Initializing backend libs
[2023-09-21 17:46:13] Initializing game data
[2023-09-21 17:46:13] Opened game data file: ac2game.dta
[2023-09-21 17:46:13] Game data version: 19
[2023-09-21 17:46:13] Compiled with: 2.51
[2023-09-21 17:46:13] Startup directory: ./
[2023-09-21 17:46:13] Data directory: ./
[2023-09-21 17:46:13] Setting up game configuration
[2023-09-21 17:46:13] WARNING: FSNode::createDirectory: './.' already exists!
[2023-09-21 17:46:13] Unable to init voice pack 'speech.vox', file not found or of unknown format.
[2023-09-21 17:46:13] Initializing TTF renderer
[2023-09-21 17:46:13] Initializing mouse: number of buttons reported is 3
[2023-09-21 17:46:13] Install timer
[2023-09-21 17:46:13] Initialize legacy path finder library
[2023-09-21 17:46:13] Game title: 'Pleurghburg: Dark Ages'
[2023-09-21 17:46:13] Game uid (old format): 1031842065
[2023-09-21 17:46:13] Game guid:
[2023-09-21 17:46:13] Game GUI version: 102
[2023-09-21 17:46:13] WARNING: font 'agsfnt0.wfn' has mistakes in data format, some characters may be displayed incorrectly
[2023-09-21 17:46:13] WARNING: font 'agsfnt1.wfn' has mistakes in data format, some characters may be displayed incorrectly
[2023-09-21 17:46:13] WARNING: font 'agsfnt2.wfn' has mistakes in data format, some characters may be displayed incorrectly
[2023-09-21 17:46:13] Checking for disk space
[2023-09-21 17:46:13] Game native resolution: 320 x 200 (16 bit)
[2023-09-21 17:46:13] Graphic settings: driver: OGL, windowed: no, screen size: 0 x 0, game scale: proportional
[2023-09-21 17:46:13] Requested graphics driver 'OGL' not found, will try existing drivers instead
[2023-09-21 17:46:13] Graphics mode set: 320 x 200 (32-bit) fullscreen desktop
[2023-09-21 17:46:13] WARNING: movement control not supported, mouse control can't be enabled!
[2023-09-21 17:46:13] Mouse speed control: disabled, unit: 1.000000, user value: 1.000000
[2023-09-21 17:46:13] Multitasking mode set: 0
[2023-09-21 17:46:13] Setting up window
[2023-09-21 17:46:13] Multitasking mode set: 0
[2023-09-21 17:46:13] Initialize sprites
[2023-09-21 17:46:13] Engine initialization complete
[2023-09-21 17:46:13] Starting game
[2023-09-21 17:46:13] WARNING: channel 2 - same clip assigned

Possibly Related: When starting the game natively on my system, the following error message occurs:

"The code execution cannot proceed because CNCS232.dll was not found. Reinstalling the program may fix this problem."

Change History (3)

comment:1 by tag2015, 8 months ago

The issue is related to the initial logo animation, which also has problems with the official AGS interpreter.
Try a 2.8.0 daily build, the initial animation is a bit glitchy but the rest of the game should play normally (I don't know if it's completable, though)

comment:2 by tag2015, 7 months ago

Hi, using today's 2.8.0 daily build the game should work, including the logo animation.

comment:3 by tag2015, 7 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.