Opened 16 years ago

Closed 16 years ago

Last modified 12 months ago

#1463 closed defect (duplicate)

Mac OS X: Mouse click don't always register when windowed

Reported by: SF/fds- Owned by: fingolfin
Priority: high Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

The problem occurs with ScummVM 0.6.0pre (built on Feb
15 2004 12:54:39), "official" snapshot. I'm running Mac OS X
10.3.2 with an ATI Mobility 9000 (32 MB) card.

It seems some kind of bounding box doesn't always get reset
correctly. The problem looks like this: whenever you move your
mouse to a position outside this "bounding box," both the game's
cursor and the default Mac OS X cursor is shown. If then you try to
click with your mouse, nothing happens. As workaround #1 you
can still press Enter on the keyboard which keeps on working even
in this case.

Workaround #2: switch to full-screen (where things are normal)
then switch back and the whole window is still nicely clickable.

The problem is triggered by non-300x200 games and/or
magnification.

As I understand, 2x magnification is the default. ZAK FMTOWNS for
example by default starts in a 640x502 window (borders and title
bar included) and while the upper three inventory slots are
clickable, rows four and five are already outside of this certain
bounding box and are not, unless you use one of the two
workarounds I described above. (You can also lower the
magnification with Ctrl-Alt-minus and the whole of the tiny window
will be clickable.)

This problem doesn't by default happen with 320x200 games such
as Indy4 PC, DOTT PC or SamNMax PC, but can still be triggered
by pressing Ctrl-Alt-= and thus switching to 3x magnification.

This is a recent problem as earlier snapshots (certain copies of
0.5.7cvs) behaved rather differently. It was quite challenging to
move the mouse cursor outside and back inside the ScummVM
window but when you finally managed to get the mouse cursor
correctly visible and working in the window you wanted, the
problem I described above didn't happen.
I very much prefer the current behavior which lets you seamlessly
move the mouse cursor in and out of ScummVM windows on Mac
OS X.

Ticket imported from: #897979. Ticket imported from: bugs/1463.

Change History (10)

comment:1 by SF/fds-, 16 years ago

I'm very sorry I didn't notice this at first:

My bug seems to be a duplicate of [ 896976 ] ZAK256: Inventory scroll
arrow does not function(osx 0.5.7)

http://sourceforge.net/tracker/index.php?
func=detail&aid=896976&group_id=37116&atid=418820

Still, my description is hopefully more accurate and to the point.

comment:2 by fingolfin, 16 years ago

Owner: set to fingolfin
Priority: normalhigh

comment:3 by fingolfin, 16 years ago

"I very much prefer the current behavior which lets you seamlessly
move the mouse cursor in and out of ScummVM windows on Mac
OS X."

-> this is not related to ScummVM at all, this is due to a newer SDL
(beta) version being used.

Anyway, I finally can reproduce the problem. The trick is to do this:
1) Make sure aspect correction is *disabled* in your config file
2) Start the launcher
3) From here start a non-320x200 game (e.g. zak256, sword1, ...)
4) Now you can observe the bug

So this is probably due to init_size being called again causing a bug...

comment:4 by fingolfin, 16 years ago

We don't even receive the click events... either this is a bug in SDL, or
we are misusing SDL somehow...

comment:5 by SF/khalek, 16 years ago

For what its worth there is a new snapshot built against an
updated version of SDL from CVS. I'm not sure if this
changes anything but I couldn't reproduce it here.

comment:6 by SF/fds-, 16 years ago

I have tried the new snapshot (Feb 17 2004 00:54:25) -- wow, fresh from
the future. :)
The problem is still there.

Also, turning on Aspect ratio correction doesn't seem to make a
difference regarding this problem on my PowerBook (1280x854 desktop
resolution).

I can confirm however that starting the game directly without using the
launcher part is a functioning workaround.
eg. /Applications/Games/scummvm/ScummVM.app/Contents/MacOS/
scummvm zakTowns

As fingolfin discovered, the problem only occurs if you start the game
through ScummVM's built-in launcher.

comment:7 by fingolfin, 16 years ago

Please read again what I wrote - I never said that turning on aspect
correction would fix the problem. In fact for games which are not
320x200, you *can't* turn on aspect correction.

However, if you have aspect correction already on when you start
ScummVM (by setting it in the config file), you can't trigger the problem.

Anyway I found the cause in the SDL sources and am looking into a fix.

comment:8 by fingolfin, 16 years ago

The bug is now fixed in SDL CVS, and should be in SDL 1.2.7 (once that
gets released).

Closing this as a duplicate of bug #896976

comment:9 by fingolfin, 16 years ago

Resolution: duplicate
Status: newclosed

comment:10 by digitall, 12 months ago

Component: --Unset--Port: Mac OS X
Note: See TracTickets for help on using tickets.