Opened 6 months ago

Closed 5 months ago

#14619 closed defect (fixed)

French translation variant for Nightmare Frames

Reported by: Guy0me Owned by: tag2015
Priority: normal Component: Engine: AGS
Version: Keywords: nightmare-frames
Cc: Game:

Description

The game in 'Nightmare Frames (USA) (T-Fr v1.0) (AGS)\' seems to be an unknown game variant.

Matched game IDs for the ags engine: nightmareframes

{"Nightmare Frames.exe", 0, "aec3371f8e8572efe5b0f601fff7913e", 2697791318},

Hello, this is the french translation of Nightmare Frames (AGS), unfortunately the game crash after the menu when i click on "new" to begin a new game, i heard the rain and after that it crash the game and i'm back on scummvm screen. I try the game in the last Git release.-09/11

Thank you.

Attachments (1)

image-20230911-195435.png (23.6 KB ) - added by Guy0me 6 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 by criezy, 6 months ago

Where is this French version available? On both Steam and itch.io only English and Spanish are listed.

comment:2 by tag2015, 6 months ago

Thanks for reporting this! Could you try the game with version 2.7.1 ? There are some problems with the AGS engine in daily dev builds.

@criezy I found the patch. Here's a link if you are interested

comment:3 by Guy0me, 6 months ago

thank you for your answer, sorry yes here is the patch > https://www.mediafire.com/file/f2puc8zvp97oxrn/Patch_Fr_Nightmare_Frames_1.00.exe/file

i tried the game on version 2.7.1 and it works ! So i hope it will works in the next git release one day ;-) because we use the git version in batocera.. i know it's risky lol..

Scummvm 2.7.1 still ask to report the game anyway..see the attached file.

thanks for your support.

Guy0me.

by Guy0me, 6 months ago

Attachment: image-20230911-195435.png added

in reply to:  2 comment:4 by criezy, 6 months ago

Since this appears to be non official and the AGS engine has a good fallback detection that allows running unknown variants, I am not too keen on adding it to the detection table.

Replying to tag2015:

@criezy I found the patch. Here's a link if you are interested

Sadly I can't do anything with this since it is distributed as a Windows executable and I don't have Windows (and wine doesn't work on my system). :-(
What does it do? Since this generates an unknown detection message I am guessing this patches the executable? I wonder why whoever made the translation decided to modify the executable rather than use for example the ags translation editor to create a .tra file. That would have made it more accessible to non-Windows users and would not have needed a change to the detection table to be recognised.

comment:5 by tag2015, 6 months ago

The patch can be extracted with innoextract. It does not alter the executable and it contains three files (and 2 minimal batch files):
acsprset.spr
sprindex.dat
English.fr
The last one is supposed to overwrite the English.tra file, while the other two translate the menus (they are loaded automatically in place of those embedded with the executable)

I tried the patch with my updated steam version and ScummVM does not report a new version , so it seems this is actually an older version, and should probably be added to the tables (currenly we have only one entry, which is the latest)

comment:6 by criezy, 6 months ago

Oh nice. I though I tried innoextract, but I apparently did not as it indeed works properly.

As you mention the bat file that is included renames the English.fr file into English.tra. I am wondering if it would work properly if it was renamed to French.tra instead. But I guess that might be an issue with the language selection menu in the game.

But since the patch does not modify the executable, I guess the reported version is indeed a genuine unknown version and should be added to the detection. @Guy0me can you confirm which version you used as the base for the patch? Is it the one from Steam, the one from itch.io, or one from somewhere else?

@tag2015 I just bought the game on itch.io and it appears to be yet another unknown variant. I will commit shortly the detection for that one.

comment:7 by Guy0me, 6 months ago

Alright i guess the version i have is a old steam release and i should try to take the new one and install the patch on it and see if there is a new detection or not.

comment:8 by tag2015, 5 months ago

Confirmed that the hash matches the original release, I added it to the tables in commit ee8b65f

comment:9 by tag2015, 5 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.