Opened 9 months ago

Closed 6 months ago

#14615 closed defect (fixed)

BBVS: Assertion failure in OpenGL::OpenGLGraphicsManager::setPalette(unsigned char const*, unsigned int, unsigned int)

Reported by: lephilousophe Owned by: sev-
Priority: blocker Component: Engine: BBVS
Version: Keywords:
Cc: Game:

Description

Version 2.7.1

Assertion failure: '_gameScreen->hasPalette()' in backends/graphics/opengl/opengl-graphics.cpp:1108 (virtual void OpenGL::OpenGLGraphicsManager::setPalette(const byte *, uint, uint))

Here is a crash report from Google Play console:

backtrace:
  #00  pc 0x0000000000052654  /apex/com.android.runtime/lib64/bionic/libc.so (abort+168)
  #01  pc 0x00000000006f305c  /apex/com.android.art/lib64/libart.so (art::Runtime::Abort(char const*)+596)
  #02  pc 0x0000000000016ea8  /apex/com.android.art/lib64/libbase.so (android::base::SetAborter(std::__1::function<void (char const*)>&&)::$_3::__invoke(char const*)+80)
  #03  pc 0x0000000000006f60  /system/lib64/liblog.so (__android_log_assert+312)
  #04  pc 0x00000000019dea98  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (__assert2+40)
  #05  pc 0x000000000366c6bc  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (OpenGL::OpenGLGraphicsManager::setPalette(unsigned char const*, unsigned int, unsigned int)+148)
  #06  pc 0x0000000001de4568  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (Bbvs::Screen::setPalette(Bbvs::Palette&)+104)
  #07  pc 0x0000000001ddb868  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (Bbvs::BbvsEngine::loadScene(int)+136)
  #08  pc 0x0000000001ddba2c  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (Bbvs::BbvsEngine::initScene(bool)+240)
  #09  pc 0x0000000001ddbe90  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (Bbvs::BbvsEngine::changeScene()+252)
  #10  pc 0x0000000001ddea7c  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (Bbvs::BbvsEngine::updateGame()+192)
  #11  pc 0x0000000001dde794  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (Bbvs::BbvsEngine::run()+644)
  #12  pc 0x00000000019e90f4  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (scummvm_main+7012)
  #13  pc 0x00000000019db3a8  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/lib/arm64/libscummvm.so (JNI::main(_JNIEnv*, _jobject*, _jobjectArray*)+340)
  #14  pc 0x00000000000222f0  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/oat/arm64/base.odex (art_jni_trampoline+128)
  #15  pc 0x00000000000544c0  /data/app/~~nlC2vvmQA-NTltdwifCOiQ==/org.scummvm.scummvm-UmOq9MKM-aS12EA_J13P7w==/oat/arm64/base.odex (org.scummvm.scummvm.ScummVM.run+656)
  #16  pc 0x00000000003fe910  /data/misc/apexdata/com.android.art/dalvik-cache/arm64/boot.oat (java.lang.Thread.run+80)
  #17  pc 0x0000000000457d6c  /apex/com.android.art/lib64/libart.so (art_quick_invoke_stub+556)
  #18  pc 0x0000000000483be4  /apex/com.android.art/lib64/libart.so (art::ArtMethod::Invoke(art::Thread*, unsigned int*, unsigned int, art::JValue*, char const*)+156)
  #19  pc 0x00000000004838b0  /apex/com.android.art/lib64/libart.so (art::JValue art::InvokeVirtualOrInterfaceWithJValues<art::ArtMethod*>(art::ScopedObjectAccessAlreadyRunnable const&, _jobject*, art::ArtMethod*, jvalue const*)+400)
  #20  pc 0x00000000005cc068  /apex/com.android.art/lib64/libart.so (art::Thread::CreateCallback(void*)+1680)
  #21  pc 0x00000000000ba5a8  /apex/com.android.runtime/lib64/bionic/libc.so (__pthread_start(void*)+208)
  #22  pc 0x0000000000053e9c  /apex/com.android.runtime/lib64/bionic/libc.so (__start_thread+68)

It looks like BbvsEngine doesn't initialize graphics mode properly.

Change History (4)

comment:1 by somaen, 6 months ago

Priority: normalhigh

comment:2 by somaen, 6 months ago

Priority: highblocker

comment:3 by sev-, 6 months ago

Summary: Assertion failure in OpenGL::OpenGLGraphicsManager::setPalette(unsigned char const*, unsigned int, unsigned int)BBVS: Assertion failure in OpenGL::OpenGLGraphicsManager::setPalette(unsigned char const*, unsigned int, unsigned int)

comment:4 by sev-, 6 months ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

Fixed. To reproduce the original bug, remove VIDEO012.AVI video, "legal crap one", that will switch the color to 16-bit and exit the method without switching back.

Note: See TracTickets for help on using tickets.