Opened 11 months ago

Closed 7 months ago

#14575 closed defect (wontfix)

WIN32: Scummvm-2.7.1-winxp-win32 builds don't work. GetTickCount64 shouldn't be used with WinXP.

Reported by: zosite Owned by: lotharsm
Priority: normal Component: Port: Win32
Version: Keywords: winxp xp win32 kernel32 gettickcount64 crash 2.7.1
Cc: Game:

Description

No scummvm-2.7.1-winxp-win32 builds seem to work under Windows XP. All them result on a "CTR+C" exit error on execution.

All scummvm-2.7.0-winxp-win32 builds work flawlessly.

It seems the actual error is "The procedure entry point GetTickCount64 could not be located in the dynamic link library KERNEL32.dll". That API was added in Vista, so should not be used in WinXP code. (Thanks for finding it out, digitall!).

Attachments (1)

d5_debug_output.txt (2.0 KB ) - added by zosite 11 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 by lotharsm, 11 months ago

Yes, that's why we removed the builds from the downloads page.

As of now, the Windows XP builds are deprecated. I recommend using the Win9x builds instead.

Last edited 11 months ago by lotharsm (previous) (diff)

comment:2 by zosite, 11 months ago

Sorry but Win95+ build didn't work under WinXP SP3 for me, not even with Win9x compatibility mode enabled and scummvm.ini created from scratch. The exact error after crashing to desktop is as follows:

WARNING: OpenGLGraphicsManager::endGFXTransaction: Could not load any graphics mode!!

Would you please provide any help on this matter? Or even better, is there any ETA for a working WinXP build? Otherwise I suppose I'll have to wait for it. Because I hope you didn't mean you actually ended WinXP support, did you?

in reply to:  2 comment:3 by ccawley2011, 11 months ago

Replying to zosite:

WARNING: OpenGLGraphicsManager::endGFXTransaction: Could not load any graphics mode!!

This sounds like it might be an issue with your OpenGL drivers - the Windows 9x build works fine for me on Windows XP. Could you try the following:

  • Running the Windows 9x release build with "./scummvm -d5" and attaching the resulting debug messages.
  • Running the Windows 9x release build with "./scummvm --gfx-mode=surfacesdl" to use software rendering instead of OpenGL.
  • Running the v2.7.0 Windows XP release build.
  • Upgrading your GPU drivers.

comment:4 by zosite, 11 months ago

Funny... finally I got Win9x build working under WinXP. The key is that SDL_VIDEODRIVER was set as "directx". If set to "windows" it doesn't work either. Finally, when I cleared the variable it worked, then the output revealed that default value is "windib" and with that one it works. Well, that means it's using SDL 1.x instead 2.x I've been using to date which maybe is normal for a Win9x build.

Having said that...

-I'm attaching requested debug output.
-v2.7.0 Windows XP release build always worked perfectly for me, and with SDL 2.x; it's 2.7.1 the first WinXP build that fails on me, apparently because of the usage of that GetTickCount64 API call which came with Windows Vista, hence being incompatible with XP.
-Upgrading my GPU drivers would be my very last choice; 344.75 is known for being one of the best and most stable WinXP drivers available for a GeForce GTX 780 Ti! Besides, now it's clear the problem is related to SDL version environment variables and not the drivers, right?

Anyway, thank you so much for your support on this! Yet still I hope to see another working WinXP build in some future...

by zosite, 11 months ago

Attachment: d5_debug_output.txt added

comment:5 by sev-, 8 months ago

Summary: Scummvm-2.7.1-winxp-win32 builds don't work. GetTickCount64 shouldn't be used with WinXP.WIN32: Scummvm-2.7.1-winxp-win32 builds don't work. GetTickCount64 shouldn't be used with WinXP.

in reply to:  4 comment:6 by vvs-, 7 months ago

Replying to zosite:

Yet still I hope to see another working WinXP build in some future...

Today when 2.8.0 is out, I was somewhat surprised to see that even Windows 9x support is gone.

Happy New Year!

comment:7 by lotharsm, 7 months ago

There's a high chance that the Windows 9x builds will return. You can use them for XP as well, because there won't be new builds dedicated to XP in the foreseeable future.

comment:8 by lotharsm, 7 months ago

Owner: set to lotharsm
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.