Opened 16 years ago

Closed 16 years ago

Last modified 12 months ago

#1457 closed defect (fixed)

OSX: Lower part of screen not clickable

Reported by: SF/bilgemonkey Owned by: fingolfin
Priority: normal Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

Simple really, the game is unplayable due to the fact I cant see
any more inventory items passed the ones at the top, also note the
remote control for the TV at the beggining does not do anything :(

Ticket imported from: #896976. Ticket imported from: bugs/1457.

Change History (35)

comment:1 by SF/ender, 16 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by SF/ender, 16 years ago

Also, the remote control works fine, you probably just forgot to
plug the TV in first.

comment:3 by SF/ender, 16 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 by SF/bilgemonkey, 16 years ago

Summary: Inventory scroll arrow does not function (osx)ZAK(256) Inventory scroll arrow does not function (osx)

comment:5 by SF/bilgemonkey, 16 years ago

CVS 0.5.7

comment:6 by SF/bilgemonkey, 16 years ago

Priority: normalblocker

comment:7 by fingolfin, 16 years ago

Works great for me on OSX.

Maybe this is a duplicate of bug #893732 (https://sourceforge.net/
tracker/?func=detail&atid=418820&aid=893732&group_id=37116)

comment:8 by fingolfin, 16 years ago

Priority: blockernormal
Summary: ZAK(256) Inventory scroll arrow does not function (osx)ZAK256: Inventory scroll arrow does not function (osx)

comment:9 by SF/bilgemonkey, 16 years ago

Summary: ZAK256: Inventory scroll arrow does not function (osx)ZAK256: Inventory scroll arrow does not function(osx 0.5.7)

comment:10 by SF/bilgemonkey, 16 years ago

Priority: normalblocker

comment:11 by SF/bilgemonkey, 16 years ago

The remote work fine now i reinstalled but the inventory arrow is
definately not working :(

comment:12 by SF/bilgemonkey, 16 years ago

I definately plugged the TV in ;)

comment:13 by SF/bilgemonkey, 16 years ago

ScummVM 0.5.7cvs
ID:zakTowns
Name: (FM Towns) (English (US)/FM-TOWNS)

comment:14 by SF/bilgemonkey, 16 years ago

Now the remote control doesnt work again :(
latest build and everything.

comment:15 by SF/bilgemonkey, 16 years ago

Doesn't seem to matter which order I do things when I start, this is the
first cvs build I have tried. I am using OS X 10.3

comment:16 by fingolfin, 16 years ago

Priority: blockernormal

comment:17 by fingolfin, 16 years ago

Did you *read* the link I posted for you?

Also, please do not mess with the priority settings. They are for team
use only.

comment:18 by SF/bilgemonkey, 16 years ago

Ok, now the remote doesn't work anymore (so what :), but I can press
the return key on the inventory arrow to access the rest. Hope this
helps.

comment:19 by SF/bilgemonkey, 16 years ago

Priority: normalblocker

comment:20 by SF/bilgemonkey, 16 years ago

Priority: blockernormal

comment:21 by SF/bilgemonkey, 16 years ago

Sorry for my ingnorance everyone, yes I went to the link and I suppose
that does make sense. Why is the priority setting freely available, it
doesn't say admin or anything?

comment:22 by fingolfin, 16 years ago

You went to the link, and did was what said there, namely downloaded
the ScummVM OSX binary referenced from there?
You never explained if you use that build, or if you compiled ScummVM
yourself.

comment:23 by SF/bilgemonkey, 16 years ago

Ok, Problems only seem to be in windowed mode, the remote and the
inventory arrow work fine in fullscreen mode, sorry for all the posts.

comment:24 by SF/bilgemonkey, 16 years ago

I just used what I asummed was the latest build from the Scumm VM
download section. As I say, please excuse my ignorance on things like
this.

comment:25 by fingolfin, 16 years ago

The issue was caused by a bug in SDL on Mac OS X. The issue is now
fixed in SDL CVS, and the fix will be in SDL 1.2.7.

Leaving this open for now, to avoid duplicates from being submitted (and
until SDL 1.2.7 gets released and I get some 3rd party to confirm the fix
;-)

comment:26 by fingolfin, 16 years ago

Component: Engine: SCUMM--Unset--
Game: Zak McKracken
Owner: set to fingolfin
Resolution: fixed
Summary: ZAK256: Inventory scroll arrow does not function(osx 0.5.7)OSX: Lower part of screen not clickable

comment:27 by SF/fds-, 16 years ago

Thanks for the swift resolution!

I pulled the latest code from the SDL and ScummVM CVS repositories
and compiled my own copy to test.

I can confirm that the problem is now fixed.

comment:28 by SF/khalek, 16 years ago

is there any particular reason this is still open?

comment:29 by SF/bilgemonkey, 16 years ago

Thanks for the fix.

comment:30 by SF/bilgemonkey, 16 years ago

Status: newclosed

comment:31 by SF/khalek, 16 years ago

reopening as it was just pointed out to me that fingolfin
explained why this was open in the comments below, not that
I closed it :)

comment:32 by SF/khalek, 16 years ago

Status: closednew

comment:33 by fingolfin, 16 years ago

Status: newclosed

comment:34 by fingolfin, 16 years ago

SDL 1.2.7 has been released now.

comment:35 by digitall, 12 months ago

Component: --Unset--Port: Mac OS X
Note: See TracTickets for help on using tickets.