Opened 15 years ago

Closed 15 years ago

Last modified 8 months ago

#1456 closed defect (fixed)

FUNPACK: puzzle blocks regression

Reported by: SF/khalek Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

When using Putt-Putt's Fun Pack there is currently a
regression when playing puzzle blocks.

While it used to work fine currently the following
assertion is triggered.

scummvm: scumm/sound.cpp:73: void
Scumm::Sound::addSoundToQueue2(int): Assertion
`_soundQue2Pos < ((int)(sizeof(_soundQue2) /
sizeof(_soundQue2[0])))' failed.

Latest CVS, Linux/x86

Ticket imported from: #896906. Ticket imported from: bugs/1456.

Change History (3)

comment:1 Changed 15 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:2 Changed 15 years ago by Kirben

Was not actually a regression, the addition of the assert just
exposed a bug (Caused by missing code).

comment:3 Changed 8 months ago by digitall

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.