Opened 15 years ago

Closed 15 years ago

#1455 closed defect (fixed)

DIG: Missing subtitle at the lab console

Reported by: SF/omega195 Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

ScummVM 0.5.7cvs (Feb 13 2004 14:03:53)
Language: English
Platform: Linux 2.6.1-r1 | GCC 3.2.3

When you put the piece of crystal you found on the
beach in the console, Low says a few things about the
machine not working and that it's still missing pieces,
but the lyrics for that don't appear.

Included is a save game. Use the console then put the
piece in the socket.

(I'm not sure if I put this in the right catagory,
please correct it if it's wrong.)

Ticket imported from: #896844. Ticket imported from: bugs/1455.

Attachments (1)

dig.s01 (33.5 KB) - added by SF/omega195 15 years ago.
The Dig savegame

Download all attachments as: .zip

Change History (3)

Changed 15 years ago by SF/omega195

Attachment: dig.s01 added

The Dig savegame

comment:1 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:2 Changed 15 years ago by fingolfin

The problem is caused by the actor (Low in this case) not being in the
room (the alien console is a "room" of its own) while the text is spoken.
ScummVM tries to position the text near the actor, but due to different
room dimensions etc., the text end up offscreen.

The fix is to check for the actor being off-screen, and if he is, do not
position the object near the actor (rather revert to the default text
positioning).

Note: See TracTickets for help on using tickets.