Opened 8 months ago

Closed 8 months ago

#14526 closed defect (wontfix)

SCUMM/HE: bad id 544D53 in Backyard Football

Reported by: eaglesfan3 Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords: bad id 544D53
Cc: eaglesfan3 Game: Backyard Football

Description

i was trying to launch backyard football on Win32 scummvm 2.8.0 july 2nd daily build, and i got an error stating "bad id 544D53 ('.TMS.) found in index file directory!"
this has also happened on backyard soccer, and backyard baseball

how do i fix this

Attachments (1)

image-20230702-144711.png (22.4 KB ) - added by eaglesfan3 8 months ago.

Download all attachments as: .zip

Change History (6)

by eaglesfan3, 8 months ago

Attachment: image-20230702-144711.png added

comment:1 by PushmePullyu, 8 months ago

I can not reproduce the problem. Environment: Fedora Workstation 37 x86_64 with 98552301975d5816a3dc82e22c21c7b02acb58ca and Windows 10 x86_64 with 2.8.0git5687-g410851150a6 (Jul 3 2023 00:15:16). Tested with both the Windows and Mac files from the 1999 US release of Backyard Football. The game launched and I was able to start a "Single Game".

Could you provide the following information:

  • The version of Backyard Football you are using
  • Your operating system and CPU
  • A list of the files in the game directory and their MD5 hashes

Instructions to create this list on Windows 10:

  • Navigate to the game folder using the Windows file explorer (the folder shown in ScummVM's Game Options->Paths->Game Path).
  • In the explorer's "File" menu, select "Open Windows PowerShell".
  • Paste the following into the PowerShell:
Get-ChildItem . -recurse -force -file | Select-Object -Property @{name="File";expression={$_.fullName | Resolve-Path -Relative}},Length,@{name="MD5";expression={(Get-FileHash -Algorithm md5 $_.fullName).hash.toLower()}} | ConvertTo-Csv | Set-Clipboard

and press return.

  • The resulting file list will be copied to your clipboard, which you can then paste here or save to a text file and upload.

comment:2 by dwatteau, 8 months ago

Summary: bad id 544D53SCUMM/HE: bad id 544D53 in Backyard Football

Looks similar to issue #12550.

Does this game come from a legitimate, owned release? People often report using "ISOs" for those games (and run into issues), but we offer no support for them.

in reply to:  1 comment:3 by eaglesfan3, 8 months ago

Replying to PushmePullyu:

Could you provide the following information:

  • The version of Backyard Football you are using | not sure what you mean by this, im assuming which year, which im using the version you tested
  • Your operating system and CPU | windows 10 8th gen intel i7
  • A list of the files in the game directory and their MD5 hashes
    Get-ChildItem . -recurse -force -file | Select-Object -Property @{name="File";expression={$_.fullName | Resolve-Path -Relative}},Length,@{name="MD5";expression={(Get-FileHash -Algorithm md5 $_.fullName).hash.toLower()}} | ConvertTo-Csv | Set-Clipboard
    

not sure what the code above does because when i tried it, it didnt do anything. the odd thing is the error isnt occurring anymore, which is sort of strange since all i did was turn off my computer to go to sleep.

in reply to:  2 comment:4 by eaglesfan3, 8 months ago

Replying to dwatteau:

Looks similar to issue #12550.

Does this game come from a legitimate, owned release? People often report using "ISOs" for those games (and run into issues), but we offer no support for them. | i downloaded it from a website that labeled it as "for SCUMMVM" so im not entirely sure where the files come from. They've worked well in the past and have only given me problems up until yesterday and the error isnt occurring anymore.

comment:5 by AndywinXp, 8 months ago

Owner: set to AndywinXp
Resolution: wontfix
Status: newclosed

i downloaded it from a website that labeled it as "for SCUMMVM" so im not entirely sure where the files come from. They've worked well in the past and have only given me problems up until yesterday and the error isnt occurring anymore.

Okay, I guess we can close this; we do not endorse piracy and we cannot offer support for a copy illegally downloaded off the internet.

Note: See TracTickets for help on using tickets.