Opened 8 months ago

Closed 8 months ago

#14521 closed defect (fixed)

SWORD1: Broken Sword 1 softlock at the Hospital

Reported by: hitmarty Owned by: PushmePullyu
Priority: normal Component: Engine: Sword1
Version: Keywords:
Cc: Game: Broken Sword 1

Description

2.8.0git4959-g5e4740776f9
OS win 10
German Cd Version

When i click on the wall socket, the floor polisher disappears and i can no longer interact with the game. this happens always after restoring the savegame before the softlock, which i have attached to the ticket.

Attachments (4)

sword1.012 (22.7 KB ) - added by hitmarty 8 months ago.
sword2.001 (201 bytes ) - added by hitmarty 8 months ago.
sword1.001 (26.2 KB ) - added by hitmarty 8 months ago.
scummvm-sword1-win-de-00005.png (483.9 KB ) - added by hitmarty 8 months ago.

Download all attachments as: .zip

Change History (9)

by hitmarty, 8 months ago

Attachment: sword1.012 added

by hitmarty, 8 months ago

Attachment: sword2.001 added

by hitmarty, 8 months ago

Attachment: sword1.001 added

by hitmarty, 8 months ago

comment:1 by criezy, 8 months ago

Thank you for your report. What you describe is a known script bug but it was supposed to be fixed in ScummVM (see bug #1575). The commit that supposedly fixed it is https://github.com/scummvm/scummvm/commit/b14251415153c2862e0a69d14be6191da537c60f (and the workaround is still in place in the current ScummVM code).

I assume your savegame was not created with a version of ScummVM prior to 0.7.0?

We had another report of the issue after it was fixed in bug #3861 that was eventually closed due to not getting the necessary information to investigate further. At that time we were unable to reproduce the issue with fresh savegame, which suggest this might be related to something present in the savegame and resulting from actions done before it was created. Thus it would be good to have as much information as you can give us on what you did before the save.

comment:2 by hitmarty, 8 months ago

i remember before creating the savegame, i saved my game while the old guy was walking back to his machine. maybe the bug happens because of saving in this sequence?

thx for the quick reply

comment:3 by lotharsm, 8 months ago

Summary: Broken Sword 1 softlock at the HospitalSWORD1: Broken Sword 1 softlock at the Hospital

in reply to:  2 comment:4 by PushmePullyu, 8 months ago

Replying to hitmarty:

i remember before creating the savegame, i saved my game while the old guy was walking back to his machine. maybe the bug happens because of saving in this sequence?

Thanks for the info. I think your suspicion is correct. Could you try with this PR: https://github.com/scummvm/scummvm/pull/5132?

comment:5 by criezy, 8 months ago

Owner: set to PushmePullyu
Resolution: fixed
Status: newclosed

The pull request has been merged and I have tested that it works in various scenarios.

Thank you PushmePullyu for the fix.

Note: See TracTickets for help on using tickets.