Opened 15 years ago

Closed 12 years ago

#1452 closed defect (fixed)

DIG: Missing subtitles when talking to Brink

Reported by: SF/omega195 Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

ScummVM 0.5.7cvs (Feb 13 2004 14:03:53)
Language: English
Platform: Linux 2.6.1-r1 | GCC 3.2.3

When brink is at the place with the relic and you click
on him it takes a bit of time for brink to stop
building/repairing the relic. In the mean time you can
move your invisible cursor around and highlight him and
the relic. You won't see the cursor, but the words
brink and relic will still show in the bottom part of
the screen.

Furthermore if you stop the conversation by clicking in
the scenery or the stop sign. Low will say "Nevermind"
but the subtitle for this doesn't show up.

See the included savegame.

I used todays CVS.

Ticket imported from: #896489. Ticket imported from: bugs/1452.

Attachments (1)

dig.s01 (31.6 KB) - added by SF/omega195 15 years ago.
The Dig savegame

Download all attachments as: .zip

Change History (13)

Changed 15 years ago by SF/omega195

Attachment: dig.s01 added

The Dig savegame

comment:1 Changed 15 years ago by Kirben

I just checked these issues in the original version of The Dig:
Object names been shown when cursor is hidden is a bug in
the original game.
The original game doesn't play any speech or show any
subtitles, when ending a conversation with Brink at that
location.

The script (88) used for Brink conversation doesn't always
wait after messages and the original game just skips
speech/subtitles if there is no wait (For message).
Bug #896060 is a similar issue.

A sample from the script (88) for this conversion.
[01F5] (5D) if (var315 >= 12) {
[01FF] (5D) if (var315 == 12) {
[0209] (BA) talkActor("/STOP.009/Never mind.",3)
[0223] (73) } else {
[0226] (BA) talkActor("/STOP.013/Why do I bother?
Talking to you is a waste of time.",3)
[0269] (**) }
[0269] (73) } else {
[026C] (BA) talkActor("/STOP.014/Thanks.",3)
[0282] (**) }

comment:2 Changed 15 years ago by fingolfin

What do you mean when you say "[it] just skips speech/subtitles" -- skip
as in "they are not even shown at all", or skip as in "They are shown and
start playing, but the next speech/subtitles immediately override them
again" ...

comment:3 Changed 15 years ago by Kirben

I mean the subtitles aren't shown at all and the speech isn't
played.

comment:4 Changed 15 years ago by fingolfin

So the bug here is simply that Low shouldn't say "Nevermind" at all,
correct?

If so, the bug title should be changed to reflect that...

comment:5 Changed 15 years ago by fingolfin

Summary: DIG: Cursor hidden, still possible to hightlight objectsDIG: Cursor hidden, still possible to highlight objects

comment:6 Changed 15 years ago by Kirben

Summary: DIG: Cursor hidden, still possible to highlight objectsDIG: Missing subtitles when talking to Brink

comment:7 Changed 15 years ago by Kirben

Yes, although it would be good if ScummVM could still show
those sutitles since this would have been a script bug in
original game.

comment:8 Changed 14 years ago by Kirben

The problem of missing subtitles as a convesation ends,
happens in several locations. The problem occurs in some
other dialog too, ie when the entering crypt.
So it would be best if ScummVM was changed to the match
the original game, skipping the speech/subtitles completely..

The current code for playing speech in ScummVM seems to
be correct for COMI, but not the Dig.
The problem is due to speech been played earlier through
actorTalk() in ScummVM. While the original version played
speech at later point, through CHARSET_1().

comment:9 Changed 13 years ago by sev-

What is the status of this item?

comment:10 Changed 13 years ago by Kirben

Unchanged, the problem still occurs.

comment:11 Changed 12 years ago by sev-

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:12 Changed 12 years ago by sev-

I fixed bug with missing subtitles by inserting wait.waitForMessage() after all messages where it is missing.
Also since this script is common for all conversations, I think it auto-fixed other places.

As of objects being selectable, I did not investigate into it, and it does not have any impact on the gameplay, and is hardly noticeable.

Backported to 0.11.0 too. Whee, this bug is almost 4 years old!

Note: See TracTickets for help on using tickets.