#14477 closed defect (fixed)

AGS: No image for Blackwell Legacy saves in ScummVM Launcher

Reported by: Thunderforge Owned by: tag2015
Priority: normal Component: Engine: AGS
Version: Keywords:
Cc: Game:

Description

In The Blackwell Legacy (blackwell1), save games do not have an image in the ScummVM launcher

Reproduction Steps

  1. In the game, create a save
  2. Return to the ScummVM Launcher
  3. Go to the launcher's load game screen for *The Blackwell Legacy*

In both grid view and list view the save games do not have any image.

Versions Tested

  • ScummVM 2.8.0git 2023-05-23, Windows x64
  • The Blackwell Legacy, Steam release

Attachments (1)

Blackwell No Icons.png (22.3 KB ) - added by Thunderforge 12 months ago.

Download all attachments as: .zip

Change History (9)

by Thunderforge, 12 months ago

Attachment: Blackwell No Icons.png added

comment:1 by Thunderforge, 12 months ago

Component: --Unset--Engine: AGS

comment:2 by tag2015, 12 months ago

Yes, this is a generalized issue.
In short, AGS game saves have no thumbnail unless the game itself uses that feature (such as "The Cat Lady", or "Quest for glory II", etc)
It's been like that for some time, I don't know if it was changed on purpose for compatibility reasons or if it's a side effect / loss of functionality.

comment:3 by Thunderforge, 12 months ago

So you're saying that some ScummVM games have thumbnails with savegames in the original interpreter, but this game does not and that's why we don't have it?

It seems to me like we could just have ScummVM take a screenshot upon save and use that. This could either be limited to games without built-in functionality (if we can distinguish between the two). If for some reason we can't, I would guess that overriding the built-in functionality would still result in a functionally equivalent thumbnail.

in reply to:  3 comment:4 by tag2015, 12 months ago

Replying to Thunderforge:

So you're saying that some ScummVM games have thumbnails with savegames in the original interpreter, but this game does not and that's why we don't have it?

Precisely

It seems to me like we could just have ScummVM take a screenshot upon save and use that. This could either be limited to games without built-in functionality (if we can distinguish between the two). If for some reason we can't, I would guess that overriding the built-in functionality would still result in a functionally equivalent thumbnail.

It's a bit more complicated actually, because of how the AGS engine manages the saves. Forcing the engine to save the screenshot in any case is trivial but as I said, maybe it was changed to avoid appending the screenshot data if not required.

If you want to try and can build from git, it's just a matter of commenting out line 883 in ags/engine/ac/game.cpp:

if (_GP(game).options[OPT_SAVESCREENSHOT] != 0)

comment:6 by tag2015, 12 months ago

After some testing with old and recent games (both using the GMM and the in-game menus) I couldn't find any issues, so I restored the old functionality.

Bug should be fixed now

comment:7 by tag2015, 11 months ago

The old behaviour has been reinstated, and now we also have a gameflag to disable the automatic
thumbnail/screenshot creation if needed.

Closing as fixed

comment:8 by tag2015, 11 months ago

Owner: set to tag2015
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.