Opened 12 months ago

Closed 7 months ago

#14472 closed defect (fixed)

NANCY: SCK - Wrong colors on BE target

Reported by: raziel- Owned by: fracturehill
Priority: normal Component: Engine: Nancy
Version: Keywords: endian conversion
Cc: Game: Nancy Drew: Secrets Can Kill

Description

ScummVM 2.8.0git (May 15 2023 22:17:09)
Using SDL backend with SDL 2.26.5
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 MikMod Theora VPX AAC A/52 FreeType2 FriBiDi JPEG PNG GIF cloud (servers, local) ENet SDL2 TinyGL OpenGL (with shaders)

See attached screenshot, color conversion gone wrong (if there is any)

Nancy Drew: Secrets Can Kill (Windows/English)

AmigaOS4 - PPC - Big Endian
gcc (adtools build 11.3.0) 11.3.0

Attachments (1)

Nancy Drew File 01 Secrets Can Kill (Windows English)_001.png (360.5 KB ) - added by raziel- 12 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 by fracturehill, 8 months ago

Owner: set to fracturehill
Resolution: assigned
Status: newpending

I'm obscenely late on responding to this, my apologies :)
The issue seems to be a simple case of image/video data endianness not being converted. I've just pushed what I believe is a fix, but I don't have a big endian machine to test it on, so I'd appreciate if you gave it a try to confirm.

comment:2 by raziel-, 8 months ago

No problem, thank you very much.

I will test asap...unfortunately that will have to wait till october since im back at work, sorry :-/

comment:3 by raziel-, 8 months ago

Resolution: assignedfixed
Status: pendingclosed

@fracturehill

Confirmed fixed :-D

Sorry for the delay

comment:4 by raziel-, 7 months ago

Resolution: fixed
Status: closednew

Sorry, but the wrong colors are back :-/

Somehow a regression snuck in

in reply to:  4 comment:5 by fracturehill, 7 months ago

Yes, I rewrote the engine's resource management last week and apparently broke the LE->BE conversion. I've pushed a fix to master, let me know if everything works correctly.

comment:6 by raziel-, 7 months ago

Fixed again :-)

Thanks a lot for the instant reaction

comment:7 by fracturehill, 7 months ago

Resolution: fixed
Status: newclosed

No, thank you for testing! I'm re-marking this as resolved, hopefully this will be the last time I touch this ticket :)

Note: See TracTickets for help on using tickets.