Opened 14 months ago

Last modified 7 months ago

#14462 new defect

STARK: Only actors are visible in OpenGL 1.3 rendering mode

Reported by: dwatteau Owned by: dwatteau
Priority: high Component: Engine: Stark
Version: Keywords:
Cc: Game: The Longest Journey

Description

This is with ScummVM 2.7.0 (and current Git HEAD) on OSX PPC Tiger, on an old iBook G4 with an ATI Radeon 9200 that's limited to OpenGL 1.3.

When using the OpenGL rendering mode on this machine, I can't see anything, except for the actors. Even the menu is blank.

I'm attaching the -d6 output and some screenshots.

As discussed in the #engines-3d channel on Discord on 2023-01-22, a possible explanation for this was maybe the lack of "NPOT texture" on this setup?

Some further notes:

  • I'm not using any shader.
  • Rendering of this game is OK on the same machine using the TinyGL software renderer.
  • The same machine properly displays Grim Fandango and Driller, whether in TinyGL or OpenGL mode.
  • The OpenGL renderer is OK on a "newer" PowerBook with an ATI Radeon 9600 XT (which supports OpenGL 2.0 and NPOT textures).

Attachments (3)

scummvm-tlj-win-00000.png (29.9 KB ) - added by dwatteau 14 months ago.
Example of rendering issue in OpenGL 1.3 rendering mode
scummvm-tlj-win-00003.png (11.5 KB ) - added by dwatteau 14 months ago.
Other example of rendering issue. Note that the cursor at the top is also blank
stark-d6-ibook-g4-opengl13.txt (850 bytes ) - added by dwatteau 14 months ago.
ScummVM -d6 output on the iBook G4 with OpenGL 1.3

Download all attachments as: .zip

Change History (6)

by dwatteau, 14 months ago

Attachment: scummvm-tlj-win-00000.png added

Example of rendering issue in OpenGL 1.3 rendering mode

by dwatteau, 14 months ago

Attachment: scummvm-tlj-win-00003.png added

Other example of rendering issue. Note that the cursor at the top is also blank

by dwatteau, 14 months ago

ScummVM -d6 output on the iBook G4 with OpenGL 1.3

comment:1 by somaen, 8 months ago

Priority: normalhigh

comment:2 by dwatteau, 7 months ago

Owner: set to dwatteau
Resolution: fixed
Status: newclosed

Fixed in ScummVM 2.8.0pre.

comment:3 by dwatteau, 7 months ago

Resolution: fixed
Status: closednew

Oops, my bad, it works in software rendering mode, but the issue is still there in 2.8.0pre in OpenGL rendering mode.

Note: See TracTickets for help on using tickets.