Opened 10 months ago

Closed 9 months ago

#14425 closed defect (invalid)

XEEN: gog.com game variant

Reported by: yarolig Owned by: yarolig
Priority: normal Component: Engine: MM: Xeen
Version: Keywords:
Cc: Game: Might and Magic: World of Xeen

Description

Hello.

I got a game from gog.com and it is not detected by latest ScummVM.

It is an English version labelled 1.0.

Details:
installer name: setup_might_and_magic_4-5_-_world_of_xeen_1.0_(28066).exe

md5 sums:
89d5c3a3a31fdaf5868728b64541c9bd DARK.CC
60933c74b1ddb2a6b93b86757b0995e4 XEEN.CC

sizes:
11217676 DARK.CC
13435646 XEEN.CC

The cloud side plays well in branch-2-5-1. Did not tried dark side yet.

Please add this game to detection_tables

Change History (3)

comment:1 by yarolig, 10 months ago

Oh. By the way.

I have installed German version from GOG. And English Swords of Xeen.

Here is data:

setup_might_and_magic_4-5_-_world_of_xeen_1.0_(german)_(28066).exe
aa0d414266824e87368e5667cd76351a 11168312 DARK.CC
08ec9a6ee8a4c2552c5bbfd796f8abdf 13214150 XEEN.CC

The game starts in branch 2-7 and shows warning that in not fully yet supported. I walked around a bit on two sides.

setup_might_and_magic_-_swords_of_xeen_1.0_(28044).exe
938e27ccafb9df3fbac06e0b4db74ec1 13026924 SWRD.CC

The game starts in branch 2-7. I walked around a bit.

comment:2 by tag2015, 9 months ago

Hi, thanks for your report but I don't understand what we are supposed to do here.

Branch 2.5.1 is old and won't get updates, we won't add entries to that version.

Are the games properly detected in branch 2.7.0 or not? I have the same GOG versions and saw no problems at all. Also, the checksums you provided are calculated using the full file, while in scummvm only the first 5000 bytes are used, for performance reasons.

comment:3 by yarolig, 9 months ago

Owner: set to yarolig
Resolution: invalid
Status: newclosed

Hello.

My mistake. I rechecked master and some new branches. All 3 versions detected properly.
Looks like I misunderstood game detection logic.

I got a message about unknown version some time ago but can't reproduce it now.

Note: See TracTickets for help on using tickets.