Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1442 closed defect (fixed)

FT: Unable to get Hover Lift at Gorge

Reported by: SF/niobium41 Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

When attempting to get the Hover Lift at the Poyahoga
Gorge, Nester never crashes at the fertilizer truck, Ben
drives past the truck and just keeps going. Debugger
gives error message "appendable memory buffer-overflow
[B]"

Ticket imported from: #892909. Ticket imported from: bugs/1442.

Attachments (1)

fta.s02 (12.5 KB) - added by SF/niobium41 15 years ago.
Stuck at bridge Savegame

Download all attachments as: .zip

Change History (16)

comment:1 Changed 15 years ago by SF/niobium41

Summary: Unable to get Hover Lift at GorgeFT: Unable to get Hover Lift at Gorge

comment:2 Changed 15 years ago by fingolfin

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 Changed 15 years ago by SF/omega195

ScummVM 0.5.7cvs (Feb 9 2004 02:02:07)
Linux 2.6.1-rc1 / GCC 3.3.2

This works fine in the CVS version. (I just got the latest
version, as I always do when testing.)

Are you sure you loosened the tires and then kicked it down
before you tried it?

comment:4 Changed 15 years ago by SF/theraraavis

I also have the same problem.
Version: 0.5.7cvs (Feb 9 2004 12:44:26)
Language: English
Game: Talkie
Platform: Win32 Nightly Build (Precompiled)

I have never seen this work since I've started following the
nightly builds. (approx. 02/01)

OT, but possibly relevant: I've noticed that on the "fertilizer
truck" screen, if you leave the screen by going "up", the
driving animation seems to start at the bridge going towards
the mink ranch, and not from the truck, as I pass the truck
on the way to the mink ranch even though I was coming from
the truck...

I can provide a savegame if needed.

Thanks!

comment:5 Changed 15 years ago by SF/nolange

ScummVM version: 0.5.7 CVS (state ~ 30.1.04)
Compiler: Win32, MSVC7.1
German Talkie-Version of FT

Just got to add that I had the same Problem, I tried 3-5
times(saved and restarted scummvm inbetween) until it
worked. I was able to finish the game.

comment:6 Changed 15 years ago by SF/niobium41

Version: 0.5.7cvs (Feb 9 2004 12:44:26)
Language: English
Game: Talkie
Platform: Win32 Nightly Build (Precompiled)

Sorry about the lack of Info,
My results are identicle to Theraraavis' results.

Truck has been tipped, it shows the animation of Ben driving
though the spilled fertilizer, the music stutters then it jumps
back to Driving to the Bridge.

And yes, I also get the problem when trying to Driving to the
mink ranch from the truck and passing the truck again.

Changed 15 years ago by SF/niobium41

Attachment: fta.s02 added

Stuck at bridge Savegame

comment:7 Changed 15 years ago by SF/niobium41

Save game attached.

comment:8 Changed 15 years ago by sev-

Status: newclosed

comment:9 Changed 15 years ago by sev-

Bot bugs are fixed in CVS.

comment:10 Changed 15 years ago by fingolfin

Sev, please always set the resolution field when you close a bug report.
Thanks!

comment:11 Changed 15 years ago by fingolfin

Resolution: fixed

comment:12 Changed 15 years ago by SF/theraraavis

I just checked out the CVS and compiled a few minutes ago
and played the game from the start until the fertilizer scene.
Both bugs are still appearing for me.

comment:13 Changed 15 years ago by SF/theraraavis

I just checked out the CVS and compiled a few minutes ago
and played the game from the start until the fertilizer scene.
Both bugs are still appearing for me.

comment:14 Changed 15 years ago by sev-

Anonymous CVS ususally takes about 12 hours to sync. Just
try next CVS build.

comment:15 Changed 15 years ago by SF/theraraavis

Newbie mistake. My apologies. It's working fine now. Thanks!

Note: See TracTickets for help on using tickets.