#14400 closed defect (fixed)

GUI: GRAPHICS: Selection highlighter broken in Save dialog.

Reported by: macca8 Owned by: sev-
Priority: normal Component: GUI
Version: Keywords:
Cc: Game:

Description (last modified by macca8)

After opening a Save dialog in list view, the first time any empty slot, or saved game that isn’t write protected, is selected, a green highlight bar is displayed, with the flashing text-insert cursor (and its white mask(?)) overlaying the bar (see attached screenshot).

If another slot (empty or occupied) is then selected without having saved, the new slot now displays the flashing text-insert cursor correctly (if not write protected), but without the expected green highlight bar (see attached screenshot).

The issue appears to be initiated by the presence of the text-insert cursor’s mask when the cursor is first displayed in the dialog, and affects all subsequent switches (whether or not the cursor is displayed).

I’m testing 2.8.0git3759-g6c45026b (Apr 11 2023) on macOS 10.11.6, but this bug dates back to before 4 March 2023 (restricted to 2.8.0git daily builds).

To reproduce:

  • Open any game’s Save dialog.
  • If necessary, switch the dialog to list view.
  • Select any slot or saved game that’s NOT write protected.
  • Without clicking Save, select another slot.

If necessary, you can test either the 2.7.0 release or any recent 2.7.1pre stable build to compare the expected behaviour.

Attachments (2)

First selection.png (41.7 KB ) - added by macca8 15 months ago.
Second selection.png (68.4 KB ) - added by macca8 15 months ago.

Download all attachments as: .zip

Change History (6)

by macca8, 15 months ago

Attachment: First selection.png added

by macca8, 15 months ago

Attachment: Second selection.png added

comment:1 by macca8, 15 months ago

Description: modified (diff)

comment:2 by antoniou79, 15 months ago

I can reproduce this on Windows 10 with current master HEAD (2.8.0git).

The cursor flashing also looks glitchy (the white mask(?) thing)

Bisecting points to this commit as the offensive one:

commit bd52062fa7dd267b0a927bcf1bc6daa022bfe641
Author: hax0kartik <agarwala.kartik@gmail.com>
Date:   Wed Mar 1 02:42:15 2023 +0530

    GUI: Make text selectable

 gui/widgets/editable.cpp | 187 +++++++++++++++++++++++++++++++++++++++++++++--
 gui/widgets/editable.h   |  14 ++++
 2 files changed, 194 insertions(+), 7 deletions(-)

https://github.com/scummvm/scummvm/commit/bd52062fa7dd267b0a927bcf1bc6daa022bfe641

in reply to:  2 comment:3 by macca8, 15 months ago

Replying to antoniou79:

The cursor flashing also looks glitchy (the white mask(?) thing)

My bad. I should have clarified that that behaviour was also unexpected, since it's clearly part of the issue.

Thanks for confirming, and tracking the source of the problem!

comment:4 by sev-, 15 months ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

This has been fixed by disabling selection for the lists

Note: See TracTickets for help on using tickets.