#14393 closed defect (duplicate)

SCUMM: The secret of monkey island, 900.lfl missing

Reported by: tebra-jl Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Monkey Island 1

Description

scummvm version 2.7.0 on iPad
Monkey1 floppy vga
« ERROR: loadCharset(0): Missing file charset: 900.LFL! » when loading save game.

Attachments (1)

monkey-vga.s03 (17.9 KB ) - added by tebra-jl 11 months ago.
Save file

Download all attachments as: .zip

Change History (7)

by tebra-jl, 11 months ago

Attachment: monkey-vga.s03 added

Save file

comment:1 by AndywinXp, 10 months ago

Summary: The secret of monkey island, 900.lfl missingSCUMM: The secret of monkey island, 900.lfl missing

comment:2 by AndywinXp, 10 months ago

Hi! Does this happen on all savegames you are saving?

comment:3 by AndywinXp, 10 months ago

Also, how are you saving the savegames? With the ScummVM menu? With the original save menu?

comment:4 by AndywinXp, 10 months ago

Which audio settings are applied to the game? Namely, is it Adlib? MT-32? Other?

comment:5 by tebra-jl, 10 months ago

I use ScummVM menu to save my games. It append to all previous savegames.
The bug append only when I load a savegame that was saved with CMS music. Now scummvm is configured with fuidsynth. I can start a new game. If I go back to CMS I can load my previous savegames.
So it is not possible to continue a game with fuidsynth that was started with CMS?

comment:6 by AndywinXp, 10 months ago

Owner: set to AndywinXp
Resolution: duplicate
Status: newclosed

Ooh! :-) Yes, that is a known issue; to put it briefly, you should always save and load games with the matching audio driver. When you don't, you are basically loading an inconsistent audio state. Currently, being that it's not so trivial to find a solution for this issue, the problem is still filed under this ticket: https://bugs.scummvm.org/ticket/2693.

I'm marking this as duplicate. Thanks!

Note: See TracTickets for help on using tickets.