Opened 11 months ago

Closed 9 months ago

Last modified 9 months ago

#14387 closed defect (fixed)

SCUMM: ZAK (FM-Towns): Cannot load saves from ScummVM launcher

Reported by: mikesk8 Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Zak McKracken

Description (last modified by mikesk8)

Hi,

I have just tried to load my save files directly from the Scummvm launcher (as opposite to Start the game and Load the saves in the game), but all the saves, except for Autosave are giving me an error (pls see attachment). All the saves can be loaded from the game itself.

Mac 2.7.0 stable version.

Thanks, M.

Attachments (2)

Screenshot 2023-04-05 at 18.19.07.png (48.2 KB ) - added by mikesk8 11 months ago.
zak-fm.s03 (17.4 KB ) - added by mikesk8 11 months ago.

Download all attachments as: .zip

Change History (17)

comment:1 by mikesk8, 11 months ago

Description: modified (diff)
Game: Zak McKracken

comment:2 by AndywinXp, 11 months ago

Component: --Unset--Engine: SCUMM
Summary: Zak FM-Towns cannot load saves from Scummvm launcherSCUMM: ZAK (FM-Towns): Cannot load saves from ScummVM launcher

comment:3 by AndywinXp, 11 months ago

Thanks! I'll investigate

comment:4 by tag2015, 11 months ago

Happens when loading a save created using the original fm-towns save screen.
Saves created using scummvm's GMM are unaffected.

comment:5 by AndywinXp, 11 months ago

It seems I have to apply some post-load fixes to simulate what the original menu exit script is doing, I'll keep you updated!

by mikesk8, 11 months ago

Attachment: zak-fm.s03 added

comment:6 by mikesk8, 11 months ago

I have attached one of my save files, maybe it will help you. Thank you!

comment:7 by AndywinXp, 11 months ago

Thanks, I've been able to replicate the issue consistently, it's just going to take some time because I'll have to read the scripts for the save room and check out what's happening, because I'm not sure what it is expecting.

comment:8 by AndywinXp, 9 months ago

Where do I begin :-)

This commit, and in particular the changes in saveload.cpp are responsible for breaking saving/loading for ZAK FM-Towns. Well, not all the changes, just the runInventoryScript(0) line.

It runs a bunch of stuff which among other things: crashes the game if the steps described in this ticket are reproduced, changes the current active SCUMM variable without ever restoring it, causing the save screen to never automatically close after loading a game.

These have been a really frustrating 2 months (on and off admittedly) of research for this ticket, I must say :-P

I'll provide a fix very soon, as soon as I understand how to make both my thing and the commit above co-exist.

comment:9 by AndywinXp, 9 months ago

Owner: set to AndywinXp
Resolution: pending
Status: newclosed

I have pushed a fix to master, could you please confirm that it now works properly? (You should see the menu screen when loading such a savegame from the ScummVM launcher and then close it with ESC)

comment:10 by mikesk8, 9 months ago

I have just checked the current master branch (macosx-x86_64-master-85b9fa20), but its not working. I guess your change will be compiled later?

Thanks, M.

comment:11 by AndywinXp, 9 months ago

Resolution: pendingfixed
Status: closedpending

(Sorry, I accidentally closed the ticket instead of setting it as pending!)

Yes, it will be compiled later, that's correct

comment:12 by athrxx, 9 months ago

Thanks for fixing this. Let's hope that this experimental/guesswork call to runInventoryScript() really just breaks that one room.

Maybe that call isn't even "necessary" any more, since we have improved post-load handling in ScummEngine_v3::scummLoop_handleSaveLoad(), now (but I haven't checked).

in reply to:  9 comment:13 by mikesk8, 9 months ago

Replying to AndywinXp:

I have pushed a fix to master, could you please confirm that it now works properly? (You should see the menu screen when loading such a savegame from the ScummVM launcher and then close it with ESC)

Thank you for fixing this. I have just checked updated master and it works as you mentioned!

comment:14 by AndywinXp, 9 months ago

Status: pendingclosed

Thanks for confirming this! Hopefully down the line I will also fix the game staying on the main menu when loading an original menu save state from GMM.

comment:15 by AndywinXp, 9 months ago

Update: it appears that I managed to also fix that. Now when you reload a save you should not find yourself in the main menu.

Note: See TracTickets for help on using tickets.