Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#14368 closed defect (fixed)

Phantasmagoria Freeze in Basement

Reported by: darkshoxx Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords: original
Cc: Game: Phantasmagoria 1

Description

Game Freezes after picking up hammer in Chapter 1
See timestamp
https://www.twitch.tv/videos/1776631546?t=00h34m40s
logfile attatched as well
ScummVM 2.6.0 (I'll update soon, I swear)

Attachments (2)

scummvm.log (1.0 KB ) - added by darkshoxx 11 months ago.
2023-03-30 18_21_01-Highlighter - Twitch — Mozilla Firefox.png (16.8 KB ) - added by darkshoxx 11 months ago.

Download all attachments as: .zip

Change History (9)

by darkshoxx, 11 months ago

Attachment: scummvm.log added

comment:1 by sluicebox, 11 months ago

Any ideas on how to reproduce this? I haven't been able to so far. The video is a big help, but my guess is that your uniquely rapid input is a factor. Any input tricks? Mouse/keyboard or just mouse? I tried left clicking the fast-forward button a lot. Has this happened more than once?

comment:2 by darkshoxx, 11 months ago

Nah jsut once so far. I'll try to reproduce it. Nah, just Mouse, LMB only. I should really put the input overlay back on screen.
I'll update if it happens again

comment:3 by sluicebox, 11 months ago

Summary: Phantasmagoria Crash in BasementPhantasmagoria Freeze in Basement

Cool, I'll keep giving it a try every now and again. This one's all about reproducing; once I can do that, it'll get fixed.

comment:4 by darkshoxx, 11 months ago

Yeah reproduced it a couple times on stream today.
here's the Vod
https://www.twitch.tv/videos/1779964602
and here's a scrrenshot of the timestamps. I put markers in chat when it happened but have no idea how to export them, so this is all I can offer you timing wise, sorry.
Apparently it's not as easy to reproduce in dosbox, didn't manage to get it there.
I think you're only supposed to triple-click when going back form the Barrel-area, but you can click 4 times if you're fast, and that'll cause it.

comment:5 by sluicebox, 11 months ago

I can now reproduce this thanks to the program AutoClicker -- https://sourceforge.net/projects/orphamielautoclicker/

It lets me slam the game with fast clicks like a lunatic... uh... I mean speedrunner! =)

I quickly got the same lockup. I'll be able to debug this later and see what's going on. Progress!

comment:6 by sluicebox, 11 months ago

Keywords: original added; crash bug removed
Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Fixed in: https://github.com/scummvm/scummvm/commit/591d2a801e47d0a0fc3b38c44a8ae8564d41e12d

This is a script bug; there's a very brief moment in this particular room transition where clicking fast forward locks it up.

Thanks again for reporting!

comment:7 by sluicebox, 11 months ago

Epilogue: I've just learned that the relevant game script was changed in some versions, but that change isn't in the GOG version you have. My version has the change, and that explains why I wasn't able to reproduce this without inhuman autoclicking tools. The script change looks like it was supposed to fix this exact problem, and it mostly did, except for a tiny window that tool clicking was still able to get through.

This doesn't change my fix, but I will update the patch notes later. Hooray, everything makes sense!

Note: See TracTickets for help on using tickets.